Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

While attempting to install .NET 3.5 SP1 on a fresh install of Windows 7 RC, nothing happens. The machine gives a UAC prompt. When selecting Yes, nothing happens.

Using the full redistributable package gives the same result: nothing.

Is there a reason why the .NET 3.5 SP1 installer would suddenly quit and not proceed with installation?

share|improve this question

10 Answers 10

I just tried the installer on Windows 7 RC to see what happend, and got the following message (which happens to have the solution to your problem :)

"You must use 'Turn Windows features on or off' in the Control Panel to install or configure Microsoft .NET Framework 3.5 SP1."

Sure enough, there it is. Enable it by clicking Start --> Control Panel --> Programs --> Turn Windows features on or off. It is a checkbox right in the middle.

share|improve this answer
    
Sean is correct. The default should be it showing a "partially filled" checkbox because the underlying HTTP parts aren't installed. To check what version you are running open regedit and go here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP and you'll see the versions that are installed (as subkeys), and if there is a v3.5 subkey then there will be a version binary value with the actually version/build #. –  TheCleaner Jun 30 '09 at 21:06

I thought it was already included. Although, it would probably show a message. Try running it from the command prompt and pasting any output.

share|improve this answer

It's already included, no need to install.

share|improve this answer

I had the same problem. I solved it using this utility. http://www.computerbase.de/downloads/system/all_one_runtimes/

share|improve this answer

Once the installer fails to install and gives a message to turn on /off windows feature, it will also ask if this program ran sucessfully / run using default settings. Choose to run again using default settings and it will install .NET 3.5 this time.

share|improve this answer

I've run into this same problem trying to install SSMS 2008 (SQLManagementStudio_x64_ENU) I just tried running the install program as administrator, and got the same message that I already was getting: must have .NET 3.5 SP1 installed.

I looked around and found this post that explains how to determine what version of 3.5 is already on my computer. (I have Visual Studio 2010 RTM and it installed the latest version of .NET 4)

Looking in my own registry the 3.5 version number matched what is said to be 3.5 SP1 in this post, and in 1033 my SP value was 1, but in the parent folder, v3.5, SP was 0. Switching this SP value to 1 got rid of this problem I was having with the installer.

http://social.msdn.microsoft.com/Forums/en/vsprereleaseannouncements/thread/ea8c818c-9f11-4a4a-b5b3-eea08acd3faa

share|improve this answer

After 2 weeks trying to find how to install the framework 3.5.1 with no success. I've found out that my Antivirus (nod32) is causing all the problems i had (errors and freezing).

so after I totaly uninstalled the Antivirus (stopping the services is not enough) I installed successfully the framework through control panel -> Programs -> Turn Windows features on or off

share|improve this answer

You can download the NETframework 3.5 SP1 here ( http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=22 ) just scroll down to full package and click it

share|improve this answer

Assuming none of the other answers posted so far have worked, have you tried to run the installer by right-clicking it and choosing Run As Administrator?

share|improve this answer

If that is true then why can't I install AutoCAD 2010 when it specifies that .NET Framework 3.5 SP1 must be installed otherwise the installer crashes, which subsequently it does?

Furthermore in the 'remove programs' control panel only .NET framework 1.1 is listed. It seems so far the only way to get it for Windows 7 is that it comes with the developer SDK download available through MS website, though it's a heavy download at a gigabyte. But I cannot seem to find just the 3.5 SP1 framework by itself.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.