Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an IBM x336 that is not advertising the proper LINK speeds. One interface is the other is not. I've tried to Force it to 1000/Full but then it just shows link down. I have confirmed the switch is set to auto negotiate like my switches. I have also changed out my Ethernet Cables. I'm at a loss where to look further. I have verified that it will connect at 1G on a different swtich. This also has happened on two different servers on the same switch.

This is my output from mii-tool -v for each interface.

eth0: negotiated 100baseTx-FD, link ok
  product info: vendor 00:08:18, model 24 rev 0
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 1000baseT-HD 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
  link partner: 1000baseT-HD 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
eth1: negotiated 1000baseT-FD flow-control, link ok
  product info: vendor 00:08:18, model 24 rev 0
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 1000baseT-HD 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
  link partner: 1000baseT-HD 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD

EDIT The Fix turned out to be a bad port on the switch.

share|improve this question
    
You said that same thing is happening on other servers connected to the same switch. So, I think most probably your switch is the culprit. –  Sachin Divekar Nov 28 '11 at 7:19
    
Yes. I'm having my switch port changed. –  Squidly Nov 29 '11 at 15:54
    
@Squidly You needn't edit the title to [sovled]. Please post an answer indicating the correct resolution and mark it as accepted. –  jscott Nov 29 '11 at 16:39
    
@Squidly If you fix your own problem, the correct thing to do is answer your own question and accept it (if one of the answers already doesn't solve it). This will mark the question as correctly answered and will make it easier for others to find it useful in the future. –  MDMarra Nov 29 '11 at 16:40
add comment

2 Answers

up vote 3 down vote accepted

Have you tried changing ports on the switch for the problem connnection?

Have you tried forcing BOTH sides to a single speed, forcing just the system side may not work you should try a force on both the port side as well as the interface side.

Any information on the switch end concerning the problem port?

Have you looked at ifconfig -a to see if there are Rx/Tx errors?

Those are a few things that come to my mind off the top of my head.

share|improve this answer
    
Changing Ports was the First thing I did. I have not tried to force to 1000/Full on both sides, I will try that. 0 Errors in the interfaces. With an uptime 14 days. The time when this server was installed. –  Squidly Nov 28 '11 at 6:19
add comment

You have two options: Set both speed and duplex mode to autonegotiation on the server and the switch. Make sure that neither speed or duplex mode is fixed on any side!

OR

Fix them both at 1G/FDX.

Setting one of the two to autonegotiation and the other one to a fixed setting will not work, be it speed or duplex. You either get a very, very slow connection (DX mismatch) or none at all (speed mismatch).

share|improve this answer
    
Treid that and didn't work. –  Squidly Nov 29 '11 at 15:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.