Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently setup a new website on my linode box, everything is working fine. Except I can't seem to have a webmail subdirectory on my site. Whenever I goto http://mysite.com/webmail the browser takes me to a Google search for webmail.

But if I rename the folder to webmailzzz for example it works fine and I can reach it from http://mysite.com/webmailzzz.

I've only just moved the Name Servers to the Linode is there a possibility that something from the old host is causing an issue until it's updated properly?

EDIT: As requested here are the config files for apache.

/apache2/sites-available/mysite.com

<VirtualHost 173.255.243.240:443>
     SSLEngine On
     SSLCertificateFile /etc/apache2/ssl/apache.pem
     SSLCertificateKeyFile /etc/apache2/ssl/apache.key

     ServerAdmin email@mysite.com
     ServerName www.mysite.com
     DocumentRoot /srv/www/mysite.com/public_html/
    <Directory />
                Options Indexes FollowSymLinks
        AllowOverride None
    </Directory>
     ErrorLog /srv/www/mysite.com/logs/error.log
     CustomLog /srv/www/mysite.com/logs/access.log combined
</VirtualHost>

<VirtualHost 173.255.243.240:80>
     ServerAdmin email@mysite.com
     ServerName mysite.com
     ServerAlias www.mysite.com
     DocumentRoot /srv/www/mysite.com/public_html/
     ErrorLog /srv/www/mysite.com/logs/error.log
     CustomLog /srv/www/mysite.com/logs/access.log combined
</VirtualHost>

/apache2/apache2.conf (comments removed)

#ServerRoot "/etc/apache2" //WAS COMMENTED OUT

LockFile ${APACHE_LOCK_DIR}/accept.lock

PidFile ${APACHE_PID_FILE}

Timeout 300

KeepAlive On

MaxKeepAliveRequests 100

KeepAliveTimeout 15

<IfModule mpm_prefork_module>
    StartServers          5
    MinSpareServers       5
    MaxSpareServers      10
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

<IfModule mpm_worker_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75 
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

<IfModule mpm_event_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75 
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

AccessFileName .htaccess

<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
    Satisfy all
</Files>

DefaultType text/plain

HostnameLookups Off

ErrorLog ${APACHE_LOG_DIR}/error.log

LogLevel warn

Include mods-enabled/*.load
Include mods-enabled/*.conf

Include httpd.conf

Include ports.conf

LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

Include conf.d/

Include sites-enabled/

Edit 2 - After Chris's suggestions

Ok so after some poking around, I've narrowed it down to Firefox, as other browser are finding it ok. The only issue I have now it that on another site I setup exactly the same, that webmail folder is working fine in all browsers. GRRR!

share|improve this question
1  
Either your server is sending the redirect (very unlikely) or your browser(s) have been hijacked (malware; crapware, especially from ISPs or OEMs; possibly a "Toolbar" that came bundled with an application you installed). Check the access and error logs for httpd on the server and see what they're sending to the client. Also check perms on the webmail folder and make sure Apache can read it. –  Chris S Nov 28 '11 at 14:12
    
@ChrisS, thanks for the suggestion it has gotten me a little bit closer, I've just renamed the folder for now. –  Cubed Eye Nov 28 '11 at 14:53
add comment

2 Answers

What makes you think its got anything to do with the webserver?

Have you tried using different browsers?

Try using a tool which tells you what the browser is requesting (tamperdata, fiddler, iehttpheaders, firebug...) and see what requests the browser is sending / receiving.

share|improve this answer
    
Chrome, IE, firefox... this stuff has been built into most browsers for some time now. –  adaptr Nov 28 '11 at 13:27
add comment

It can't be a DNS-issue since you're able to reach http://mysite.com/webmailzzz.

DNS relates only to the domain-name in the URL, here mysite.com. Apparently that resolves correctly (since you can connect to the renamed subdirectory).

The Problem probably has to do with the Apache configuration. Could you please post your configuration for further help?

share|improve this answer
    
See edit for config files... –  Cubed Eye Nov 28 '11 at 14:05
    
@CubedEye: As far as I can see, the Apache configuration looks fine. –  Lukas Nov 28 '11 at 15:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.