Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a COM+ component on a different server, but when I made an update to one these components then it stopped working. How to configure MSDTC?

From the application log:

A caller has attempted to propagate a transaction to a remote system, but MSDTC network DTC access is currently disabled on machine 'NACHINE11'. Please review the MS DTC configuration settings.

I tried this http://www.howtogeek.com/howto/windows/fix-new-transaction-cannot-enlist-in-the-specified-transaction-coordinator-on-server-2003-sp2/

But it doesn't look so in Windows Server 2008 R2. Is it located somewhere else?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

On Windows Server 2008 R2, you can enable DTC and DTC network access by installing the "Application Server" role and the related role services.

share|improve this answer
    
which ones to install? –  marko Nov 28 '11 at 16:03
    
The ones you need... in your case, you'll probably need COM+ network access and distributed transactions. –  Massimo Nov 28 '11 at 17:23
    
There is no Application Server roleavailable on Windows Server 2008 R2 Web Edition –  filimonic Jun 2 at 17:10
    
Well, that's because it's... the web edition; which can only be used as a web server. –  Massimo Jun 2 at 17:36

The primary settings are configured under Admin Tools/Component Services..

From there, expand Component Services/My Computer/Distributed Transaction Coordinator/Local DTC and right click to show properties.

Specifically, compare the “security settings” tab as that determines who and what can access the DTC.

share|improve this answer
    
Everything in your answer is in the link the original poster added. –  Reaces Jan 15 at 12:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.