Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm new to server admin & Linux and have just got a VPS running CentOS 6.

Apache, MySQL and PHP all came installed (along with cPanel and WHM), however I'm now also trying to install the GD library.

I've run "yum install php-gd" and it installed ok. If I run it again I get "Package php-gd-5.3.2-6.el6_0.1.x86_64 already installed and latest version".

However, when I do a phpinfo() or from the command line "php -m" there is no mention of GD. Is there anything else I need to do?

share|improve this question
    
Did you try to restart/reload apache before checking with phpinfo? –  Khaled Nov 28 '11 at 15:59
    
Yes, sorry, I forgot to mention that I have restarted apache and the whole VPS –  gbuckingham89 Nov 28 '11 at 16:11
    
Thanks for the above help, but none of those solved the problem. Incase anyone else has the same issue, my solution is below.... Login to WHM Go to "EasyApache (Apache Update)" under Software Click "Start customizing based on profile" Hit next until you get to step 5 then click "Exhaustive Options List" at the bottom Check off GD under the PHP options Save and Build –  gbuckingham89 Nov 28 '11 at 18:41

2 Answers 2

You need to restart Apache for the new module to take effect:

# service httpd restart
share|improve this answer
    
Yes, sorry, I forgot to mention that I have restarted apache and the whole VPS. –  gbuckingham89 Nov 28 '11 at 16:08
1  
Make sure that it is enabled by extension=gd.so in /etc/php.d/gd.ini or /etc/php.ini. –  quanta Nov 28 '11 at 16:16

You have noticed that cPanel/WHM is also running on the VPS. Please take into account, that cPanel software compiles Apache/PHP and their modules from their own repos with custom flags and patches, therefore one should use their native /scripts/easyapache way of managing the LAMP bundle.

You can find more details on the official site EasyApache Docs

share|improve this answer
    
This sounds like the issue. –  gview Nov 28 '11 at 19:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.