Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm hosting some KVM virtual machines on a server with two NICs, eth0 and eth1. I have two networks 192.168.100/24 and 192.168.200/24.

I have set up bridges as per http://www.linux-kvm.com/content/using-bridged-networking-virt-manager so that the 192.168.100/24 hosts use eth0 and the other network uses eth1. This looks to be working OK.

There's a default gateway on the server routing everything to the 192.168.100.1

Each network also has its own Cobbler server on 192.168.100.222 and 192.168.200.222 handling PXE boots and DHCP.

My problem is when I PXE boot machines on the 192.168.200/24 network, I want it to reach the Cobbler server at 192.168.200.222, but it looks like it's always reaching the 192.168.100.222 server instead, probably because of the default gateway setting.

How can I configure the server so that DHCP requests coming off the eth1 bridge go to the 192.168.200.1 gateway instead of the default gateway ?

It doesn't look like I can use policy routing since there VM doesn't have an IP address yet, so what could I be overlooking?

share|improve this question
1  
Do you really need that many DHCP servers? Why don't you just have one with multiple scoped, set up DHCP forwarding on your L3 switches, and use DHCP options to tell each subnet what netboot server to use. –  MDMarra Nov 29 '11 at 18:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.