Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed PHP 5.3 on a CentOS 5.3 using yum and repos from Webtatic (http://www.webtatic.com/packages/php53/) and now I'd like to add the GD library to that installation but Webtatic seems to be offline.

Now:

# yum install php-gd

Fails of course (not the same PHP version) into: *Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-gd-5.1.6-27.el5_5.3.x86_64*

And:

# yum install php53-gd

Fails into Error: php53-common conflicts with php-common

How can I add the GD libraries now?

share|improve this question
    
You can't? You may need to find a different source for the version of PHP that you need, and then completely re-install PHP, and then include the versions you require. –  Zoredache Nov 29 '11 at 20:11
add comment

2 Answers 2

up vote 0 down vote accepted

You need to remove php-common and install php53-common

Also Centos5 has PHP 5.3.3 available, I'd remove the one from Webtatic

Then do "yum install php53"

Hopefully then the dependices will be resolved correctly because you are using ht

share|improve this answer
    
> You need to remove php-common and install php53-common How do I do this? –  Mauro Dec 6 '11 at 21:55
    
yum install php53 –  ckliborn Dec 6 '11 at 22:03
    
yum remove php-common –  ckliborn Dec 6 '11 at 22:03
1  
First remove then install –  ckliborn Dec 6 '11 at 22:04
add comment

You need to find and install the package(s) with appropriate version to meet the dependencies. Otherwise, you will have no other choice but to build and install the needed packages from source.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.