Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Hyper-V physical machine along with two standard laptops running within my LAN (connected by an ASUS-RT56U router). The physical server runs Windows Hyper-V Server 2008 R2, with two Windows Server 2008 R2 (full) guest VMs installed and running within.

Both laptops run Windows 7. All OSs are 64-bit.

Opening up Network in Windows Explorer on either of the two laptops displays both of the laptops in the LAN fine. However, neither of the guest VMs on the server (nor the host itself) are displayed. Indeed, the guest VMs can not see each other in Network view either. I can ping all computers (laptops and servers) without problems from within the LAN, but all of the servers are simply not visible from anywhere.

In addition, the Network Map screen (accessible via Network and Sharing centre) gives me an error message:

"An error happened during the mapping process."

And I'm suspecting this might have something to do with how LLTP (Link Layer Topology Protocol) is working on the network. Worth noting though is that before my server was on the network, the Network Map screen displayed fine (as far as I can remember).

share|improve this question

closed as off topic by MDMarra, mailq, Chris S, Scott Pack, Ward Nov 30 '11 at 4:17

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Please read the FAQ what is on-topic here. This is not. –  mailq Nov 30 '11 at 0:25
    
Okay, it's in a "professional setting" if that matters. Personally I don't see the difference, since I'm not a pedant. –  Noldorin Nov 30 '11 at 0:27
    
Have you disabled the firewall and started the Server Browser service? Do other services work except ICMP? What have you tried and checked? And dozens of other questions ... –  mailq Nov 30 '11 at 0:31
    
Yes, disabled firewall and started the service. Not sure about serices other than ICMP. I've confirmed many things, including that it's a Private network and Network Discovery is enabled... many I can't remember, because I've been troubleshooting for days now. –  Noldorin Nov 30 '11 at 0:38
    
Interesting. I did enabled Network Discovery on both servers (guest VMs), but it mediately switches off for some reason. –  Noldorin Nov 30 '11 at 0:45

1 Answer 1

Enable the "SSDP Discovery", "Function Discovery Resource Publication", and "UPnP Device Host" services on the Windows Servers. Then enable Network discovery.

share|improve this answer
    
Thanks for the response. In fact, I just very recently found the MSDN thread that suggested it. I now have Network discovery successfully enabled (and staying that way), but still no luck with everything else. Also, running net view from the command-line still gives the "system error 53 has occurred the network" message. –  Noldorin Nov 30 '11 at 1:37
    
I guess I have to ask, why do you even care? The network discovery junk is flaky at best, and you can just run \\servername to view shares and printer on the servers... –  Chris S Nov 30 '11 at 5:20
    
Unfortunately I need Network Map to work so that other locations are recognised on my network and I can thus set up security permissions appropriately. –  Noldorin Nov 30 '11 at 15:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.