Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have setup an Apache Tomcat 6 server and installed Apache Solr 3.5.0 as per instructions found here

Now, opening the solr application in a browser yields the following error:

HTTP Status 500 - Severe errors in solr configuration. Check your log files for more detailed information on what may be wrong. If you want solr to continue after configuration errors, change: <abortOnConfigurationError>false</abortOnConfigurationError> in solr.xml
org.apache.solr.common.SolrException: Error loading class 'solr.VelocityResponseWriter'
at org.apache.solr.core.SolrResourceLoader.findClass(
at org.apache.solr.core.SolrCore.createInstance(
at org.apache.solr.core.SolrCore.createInitInstance(

My installation is currently open to the public for test purposes:

I'm running this on a Debian 6 machine.

I did some Googling, but there is little to no documentation or anything regarding this, for Solr 3.5; most information is for 1.4 and doesn't apply to 3.5.

Note: I have no previous experience in neither Tomcat nor Solr.

share|improve this question
up vote 4 down vote accepted

I ran into this same issue on RHEL 5.3 with Tomcat 7 and solr 3.5. I just disabled the query response writer velocity inside the solrconfig file. But if you need to use velocity, which i don't, it appears that you'll need to drop some files into the lib folder.

<queryResponseWriter name="velocity" class=solr.VelocityResponseWriter" enable=false/>
share|improve this answer
Thanks - that was exactly what I needed. :) – Thomas Daugaard Dec 5 '11 at 9:21
Thanks - also just what I needed – Rasmus Apr 23 '12 at 14:17
didn't work at tomcat 7 + solr 4.2 + centos 6.4 – kamaci Mar 25 '13 at 23:02

this is a known issue with Solr 3.5 because some libraries like Velocity have been removed from the core, i assume you are using the configuration found in /example/solr and that is why you have <lib dir="../../contrib/velocity/lib" /> in your solrconfig.xml that is configured to start with Jetty, when deploying under Tomcat you have to copy the required libraries under your $SOLR_HOME directory and change the solrconfig.xml to point to the new location, if you make a new directory called lib directly under $SOLR_HOME all the libraries in there would be automatically deployed so you don't need to define any <lib> tag in solrconfig.xml

then just copy all the libraries under "dist" to the new lib folder and if you need extra functionalities like clustering or other plugins copy the libraries you need from "contrib"

and here is a mailing list discussion about this issue.

share|improve this answer

I don't know if you are familiar with it, but the /browse GUI programmed eith velocity can come in quite handy, so I would recommend you copy the velocity library to the lib folder.

The .jar file can be found in the /dist/ folder in the solr version you downloaded. Just create a folder /lib/ /$SOLR_HOME/, then put the file there and you should be ok.

I ran into the same issue with Solr 3.5. Don't understand why the library isn't included in with the .war when this is some of their default functionality though.

share|improve this answer
I am having great difficulty getting this to work. Could you explain exactly what you mean by “Just create a folder /lib/ /$SOLR_HOME/, then put the file there and you should be ok”. Create a folder called lib in the solar home folder? Put what file inside there? Does anything need to be changed in the solrconfig.xml (it currently has a tag <lib dir="../../contrib/velocity/lib" />)? Thanks – zod Jan 30 '12 at 15:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.