Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need a help on SQL Server Remote Connection Issue. I have Windows Vista with SQL Server 2005 installed.I need client to connect to my system. My client is in VB6 uses SQL Native Client.Clients which are in the same network can connect connect to my system and application runs successfully.But the clients outside the network cannot connect to my SQL Server. I have enabled TCP/IP, Named Pipes to allow remote connections on my computer.I have also allowed my sqlserver and browser to pass via firewall on Windows 7. This problem seems to be with IP Addresses. I guess I dont have public Unique IP assigned. I connect to Internet using "Broadband WAN Miniport PPPOE".In local network I can ping my system from client machine.Client machine which is in different network i cant ping to my machine... Why..? On my system IPCONFIG /ALL lists the following :

Windows IP Configuration

   Host Name . . . . . . . . . . . . : TonseTonyServer-HP
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Mixed
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : mshome.net

PPP adapter Broadband Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadband Connection
   Physical Address. . . . . . . . . :
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.150.234(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . : 0.0.0.0
   DNS Servers . . . . . . . . . . . : 192.168.150.1
                                       192.168.100.1
   NetBIOS over Tcpip. . . . . . . . : Disabled

Wireless LAN adapter Wireless Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom 4313 802.11b/g/n
   Physical Address. . . . . . . . . : CC-52-AF-96-8F-C1
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : mshome.net
   Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
   Physical Address. . . . . . . . . : 2C-27-D7-CC-2E-7D
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::d581:f5e:b4d0:c1aa%13(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.12(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 27 November 2011 10:40:36
   Lease Expires . . . . . . . . . . : 06 December 2011 10:17:24
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 288106455
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-51-8B-1E-2C-27-D7-CC-2E-7D
   DNS Servers . . . . . . . . . . . : 192.168.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

I guess my IP Address is 192.168.0.12 and if i use to ping this address from a remote computer that is on another network, packets are lost.If i use to ping from a computer within local network, ping works. I also tried OSQL -L/SQLCMD -L from a computer that is outside the local network, it says no servers.Within the network it lists my SQL server. How to connect from a computer that is outside the local network? I dont much about networking and all, Please help me..

share|improve this question
1  
This is SO MUCH not a sql server question. It is totally a network question. Clean it up and I poossibly answer, but so far my answer is: fix your network settings, then sql server will also connect. –  TomTom Nov 30 '11 at 14:54
    
TomTom is right...this is a network setup question. Out of curiosity why would someone outside of your LAN need to access SQL Server running on a Windows Vista machine? –  Top__Hat Nov 30 '11 at 17:44

1 Answer 1

up vote 2 down vote accepted

In addition to what TomTom and Top_Hat stated: You're trying to connect from the public internet (WAN) to an ip address that is only valid on your private intranet (LAN). The internal ip address of your server isn't accessible to anyone outside of your LAN. In order to connect to your LAN server from outside your LAN you need to NAT (port forward) the public ip address that you've been assigned by your ISP to the internal ip address of your server for the port that SQL Server is listening/running on.

share|improve this answer
    
Thanks for your reply. I downloaded PUTTY and now i want to install it on the client machine right? how to configure putty on client so that it connects to my pc outside that network.which IP/Port i need to enter in Putty client? do i need to install PUTTY on my PC(SQL Server) also?I dont know anything about this Port forwarding. –  Tony Dsouza Dec 1 '11 at 8:25
    
ALso i forgot to mention that we dont use client/server architecture.All ppl use WAN Miniport to connect to internet.Because Iraq is not developed yet na.I want to connect them to my pc from far locations. –  Tony Dsouza Dec 1 '11 at 8:31
    
Hello joeqwerty, I am waiting for your reply... Thank You.. –  Tony Dsouza Dec 1 '11 at 13:07
    
I don't see how Putty is relevant to your situation. You want external users to connect to your SQL server, right? If so, then they need to connect to the public ip address that's assigned to your internet connection from your ISP. External users cannot connect to your SQL server by trying to connect to it's private ip address. –  joeqwerty Dec 1 '11 at 13:36
    
I guess I need to manually port forward on Router...?but BitTorrent works on my pc without any manual configuration on router.I just want outside users to connect my SQL Server... what i need to do? Any solution would be helpfull. –  Tony Dsouza Dec 1 '11 at 14:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.