Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have one server running WHM/CPanel with quite a few (~60) low traffic sites we can't be bothered to put on a proper hosting platform.

CPanel is accessible on every domain at, however this redirects to http://servers-fqdn:2083/. I've worked on other CPanel servers where the /cpanel link redirects to so each CPanel is running under its own domain but I couldn't seem to find any documentation on how to get this to work.

Two reasons this would be useful;

  1. I frequently access the CPanel sites, but because they all redirect to the servers main hostname (and CPanel uses HTTP authentication) I can only save one username/password combination, having it on different domains would let me save each username/password individually.
  2. I would look better when our actual users log on, since the servers primary (FQDN) is reeaaallllly long

So yeah this is more for convenience than anything practical but still.

Short form;

Lots of sites with CPanel but when accessing it redirects to http://server-fqdn:2083/ redirects to http://server-fqdn:2083/

we want redirects to redirects to

Full root access to the server (I'm a real sysadmin, but users like CPanel), WHM version WHM 11.30.5, RedHat Enterprise Linux 5.5

share|improve this question

closed as off-topic by HopelessN00b Jan 13 '15 at 22:02

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

This question appears to be off-topic because it is about working with a service provider's management interface, such as cPanel. – HopelessN00b Jan 13 '15 at 22:02
up vote 3 down vote accepted

The reason why it redirects to the server hostname is so that you only have to get one SSL certificate. It is recommended to keep it at the hostname and force SSL.

That said to make it so that you can have it the way you wanted.

Login to WHM > Tweak Settings > Redirection

  • Always redirect to SSL = OFF
  • Non-SSL redirect destination = Origin Domain Name
  • SSL redirect destination = SSL Certificate Name
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.