Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The redis but usually begins with the following errors:

tyler @ tyler-vortex: ~ / pens $. / src / redis-server
[3690] Dec 01 10:56:05 # Warning: the specified config file, using the default config. In order to Specify a config file use 'redis-server / path / to / redis.conf'
[3690] Dec 01 10:56:05 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max configuration to 992 clients.

Others errors founds:

tyler@tyler-vortex:~/redis$ sudo ./utils/install_server.sh 
Welcome to the redis service installer
This script will help you easily set up a running redis server


Please select the redis port for this instance: [6379] 
Selecting default: 6379
Please select the redis config file name [/etc/redis/6379.conf] 
Selected default - /etc/redis/6379.conf
Please select the redis log file name [/var/log/redis_6379.log] 
Selected default - /var/log/redis_6379.log
Please select the data directory for this instance [/var/lib/redis/6379] 
Selected default - /var/lib/redis/6379
Please select the redis executable path [/usr/local/bin/redis-server] 
cat: ./redis.conf.tpl: Arquivo ou diretório não encontrado
cat: ./redis_init_script.tpl: Arquivo ou diretório não encontrado
ERROR: Could not write init script to /tmp/6379.conf. Aborting!

Furthermore, I would like to know how to configure it not to consume so much RAM.

Follow the memory configuration of our website, but the settings of "vm-*" does not exist in the file redis.conf. http://redis.io/topics/virtual-memory You have to create them?

* Edit:

I installed.

After that, I believe that I no longer have access via. / Src / redis-server, because it happens:

tyler@tyler-vortex:~$ cd redis/
tyler@tyler-vortex:~/redis$ ./src/redis-server 
[2616] 01 Dec 22:29:30 # Warning: no config file specified, using the default config. In order to specify a config file use 'redis-server /path/to/redis.conf'
[2616] 01 Dec 22:29:30 # Opening port 6379: bind: Address already in use
tyler@tyler-vortex:~/redis$

But there's another detail, the redistribution starts with the system ..

redis 127.0.0.1:6379> exit
tyler@tyler-vortex:~/redis$ ./src/redis-cli 
redis 127.0.0.1:6379> exit

... but how can I now see that the communication had before you installed from. sh?

share|improve this question
1  
Virtual memory is deprecated, you shouldn't use it, redis is meant to use RAM, if you're short on RAM either shift your data else where or get more. –  Rwky Dec 1 '11 at 14:04

1 Answer 1

Unable to set the max number of files limit to 10032 (Operation not permitted)

This error comes up because you're running as tyler - the normal user.

cat: ./redis.conf.tpl: No such file or directory
cat: ./redis_init_script.tpl: No such file or directory
ERROR: Could not write init script to /tmp/6379.conf. Aborting!

The shell script install_server.sh check the template files in the current working directory. So you should change to utils folder before running:

$ cd utils/
$ sudo ./install_server.sh 

Furthermore, I would like to know how to configure it not to consume so much RAM.

Follow the memory configuration of our website, but the settings of "vm-*" does not exist in the file redis.conf. http://redis.io/topics/virtual-memory

As you can see in the above link, the virtual memory feature is now deprecated, and its usage is discouraged.

share|improve this answer
    
Thank you! I edited post to add the last doubt. I've updated the question, I understand almost everything .. –  Tylër Dec 2 '11 at 0:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.