Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed a minimal centos 6 through a usb dvd writer. It worked fine. But now I can't mount the dvd writer. I can't even found the /dev/dvd device. I guess a drivers is missing, but how do I find the driver?

Some output from the system.

[root@]# lsusb
Bus 002 Device 003: ID 0000:0000  
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0409:0056 NEC Corp. 
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The NEC device is my DVD writer.

[root@]# lsusb -v # Only output for Nec driver.
Bus 001 Device 003: ID 0409:0056 NEC Corp. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x0409 NEC Corp.
  idProduct          0x0056 
  bcdDevice            0.00
  iManufacturer           1 TSST corp
  iProduct                2 USB Mass Storage Device
  iSerial                 3 000000000001
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xc0
      Self Powered
    MaxPower                2mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      5 SFF-8070i
      bInterfaceProtocol     80 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
Device Qualifier (for other device speed):
  bLength                10
  bDescriptorType         6
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  bNumConfigurations      1
Device Status:     0x0001
  Self Powered

Everything related to usb in the /dev folder.

[root]# cd /dev
[root]# find | grep usb
./.udev/links/input\x2fby-path\x2fpci-0000:00:1d.0-usb-0:1.1:1.1-mouse
./.udev/links/input\x2fby-path\x2fpci-0000:00:1d.0-usb-0:1.1:1.1-mouse/c13:33
./.udev/links/input\x2fby-id\x2fusb-ServerEngines_SE_USB_Device_40151554C56504-mouse
./.udev/links/input\x2fby-id\x2fusb-ServerEngines_SE_USB_Device_40151554C56504-mouse/c13:33
./.udev/links/input\x2fby-path\x2fpci-0000:00:1d.0-usb-0:1.1:1.1-event-mouse
./.udev/links/input\x2fby-path\x2fpci-0000:00:1d.0-usb-0:1.1:1.1-event-mouse/c13:68
./.udev/links/input\x2fby-id\x2fusb-ServerEngines_SE_USB_Device_40151554C56504-event-mouse
./.udev/links/input\x2fby-id\x2fusb-ServerEngines_SE_USB_Device_40151554C56504-event-mouse/c13:68
./.udev/links/input\x2fby-path\x2fpci-0000:00:1d.0-usb-0:1.1:1.0-event-kbd
./.udev/links/input\x2fby-path\x2fpci-0000:00:1d.0-usb-0:1.1:1.0-event-kbd/c13:67
./.udev/links/input\x2fby-id\x2fusb-ServerEngines_SE_USB_Device_40151554C56504-event-kbd
./.udev/links/input\x2fby-id\x2fusb-ServerEngines_SE_USB_Device_40151554C56504-event-kbd/c13:67
./.udev/db/usb:1-1.4
./.udev/db/usb:2-1.1
./.udev/db/usb:2-1
./.udev/db/usb:1-1
./.udev/db/usbmon:usbmon0
./.udev/db/usb:usb1
./.udev/db/usb:usb2
./.udev/db/usbmon:usbmon2
./.udev/db/usbmon:usbmon1
./input/by-path/pci-0000:00:1d.0-usb-0:1.1:1.1-mouse
./input/by-path/pci-0000:00:1d.0-usb-0:1.1:1.1-event-mouse
./input/by-path/pci-0000:00:1d.0-usb-0:1.1:1.0-event-kbd
./input/by-id/usb-ServerEngines_SE_USB_Device_40151554C56504-mouse
./input/by-id/usb-ServerEngines_SE_USB_Device_40151554C56504-event-mouse
./input/by-id/usb-ServerEngines_SE_USB_Device_40151554C56504-event-kbd
./usbmon2
./bus/usb
./bus/usb/002
./bus/usb/002/003
./bus/usb/002/002
./bus/usb/002/001
./bus/usb/001
./bus/usb/001/003
./bus/usb/001/002
./bus/usb/001/001
./usbmon1
./usbmon0

Output from /var/log/messages

Dec  1 15:24:31 vh01-tp kernel: usb 1-1.4: new high speed USB device using ehci_hcd and address 3
Dec  1 15:24:31 vh01-tp kernel: usb 1-1.4: New USB device found, idVendor=0409, idProduct=0056
Dec  1 15:24:31 vh01-tp kernel: usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Dec  1 15:24:31 vh01-tp kernel: usb 1-1.4: Product: USB Mass Storage Device
Dec  1 15:24:31 vh01-tp kernel: usb 1-1.4: Manufacturer: TSST corp
Dec  1 15:24:31 vh01-tp kernel: usb 1-1.4: SerialNumber: 000000000001
Dec  1 15:24:31 vh01-tp kernel: usb 1-1.4: configuration #1 chosen from 1 choice
Dec  1 15:24:39 vh01-tp init: tty (/dev/tty1) main process ended, respawning

Some output from /var/log/dmsg

usb 1-1: new high speed USB device using ehci_hcd and address 2
usb 1-1: New USB device found, idVendor=8087, idProduct=0020
usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
usb 1-1: configuration #1 chosen from 1 choice
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 6 ports detected
ata4: SATA link down (SStatus 0 SControl 300)
ata3: SATA link down (SStatus 0 SControl 300)
usb 2-1: new high speed USB device using ehci_hcd and address 2
usb 2-1: New USB device found, idVendor=8087, idProduct=0020
usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
usb 2-1: configuration #1 chosen from 1 choice
hub 2-1:1.0: USB hub found
hub 2-1:1.0: 8 ports detected
usb 1-1.4: new high speed USB device using ehci_hcd and address 3
usb 1-1.4: New USB device found, idVendor=0409, idProduct=0056
usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.4: Product: USB Mass Storage Device
usb 1-1.4: Manufacturer: TSST corp
usb 1-1.4: SerialNumber: 000000000001
usb 1-1.4: configuration #1 chosen from 1 choice
ata2.00: SATA link down (SStatus 0 SControl 300)
ata2.01: SATA link down (SStatus 0 SControl 300)
ata1.00: SATA link down (SStatus 0 SControl 300)
ata1.01: SATA link down (SStatus 0 SControl 300)
sd 0:0:0:0: [sda] 1953459632 512-byte logical blocks: (1.00 TB/931 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 6b 00 00 08
sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
 sda: sda1 sda2
sd 0:0:0:0: [sda] Attached SCSI disk
usb 2-1.1: new full speed USB device using ehci_hcd and address 3
usb 2-1.1: New USB device found, idVendor=0000, idProduct=0000
usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-1.1: Product: SE USB Device
usb 2-1.1: Manufacturer: ServerEngines
usb 2-1.1: SerialNumber: 40151554C56504
usb 2-1.1: configuration #1 chosen from 1 choice

Output from /proc/bus/usb/devices. As I suspected, no driver seams to be installed.

T:  Bus=01 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#=  3 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0409 ProdID=0056 Rev= 0.00
S:  Manufacturer=TSST corp
S:  Product=USB Mass Storage Device
S:  SerialNumber=000000000001
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=05 Prot=50 Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

Should I look somwhere else, or is the right info just in front of me?

share|improve this question
1  
Nevermind the question. I'm a stupid idiot that shouldn't be allowed to sit infront of a computer. I have a hardening script that adds "blacklist usb-storage" to modprobe.d. Strange that it didn't work? –  Arlukin Dec 1 '11 at 16:01
1  
Add this as an answer and accept it. It will help others. –  Mircea Vutcovici Dec 1 '11 at 18:52
add comment

2 Answers 2

/dev/dvd is a symlink to the real block device file. Search the dmesg output for the CD-ROM device. Should be something like sr0 or scd0. You can then make a symlink by yourself with: sudo ln -s /dev/<dvd_device_name> /dev/dvd.

share|improve this answer
    
Updated my question with output from dmsg. Can't find the s* device for usb 1-1.4. And in /dev I have the following s* devices sda, sda1, sda2, sg0, sg1, shm/, snapshot, stderr, stdin, stdout, systty. –  Arlukin Dec 1 '11 at 15:31
add comment
up vote 2 down vote accepted

I found that my hardening script did a "blacklist usb-storage" in a conf file in /etc/modprobe.d. I had forgot about that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.