Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm unable to boot centos 5.2. It starts and shows me menu listing, which means there is not any issue with grub.

Here is screen shot after starting server... it goes to prompt bash prompt instead of loading process.

enter image description here

Any help?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

I was about to say it may be an issue with initrd, but looking closer, it appears that you are booting to the bash prompt instead.

So it looks like it is jumping into single user mode by default. In that case, run:

init 3

(for multi-user network access)

Or:

init 5

(for multi-user network access with GUI)

if you can boot to either one, I suggest you look in /etc/inittab and make sure that it boots to the appropriate multi-user level by looking for this line:

id:3:initdefault:

EDIT: I just realize you are booting with init=/bin/bash, which meant you are bypassing /etc/inittab. In fact, I was able to reproduce it by adding init=/bin/bash within my Centos VM.

Restart again, but this time, remove init=/bin/bash.

share|improve this answer
1  
It is not single user - this has meaning if you use the stock initd. As you figure out it is the init= the problem. @User4283 has to edit the grub configuration and remove init=... parameter. –  Mircea Vutcovici Dec 1 '11 at 18:57
    
Yes it was the same problem as said by Rilindo. Mistakenly sometime i had added init=/bin/bash in grub.com that is why it was booting in bash –  User4283 Dec 1 '11 at 19:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.