Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Ok, here is the context. We've a server which is inside our network; on the server there is a Samba configured, providing access to a number of shares; there is also and Apache server providing other services (among them is also WebDav, but for svn folders, so they are different folders).

In the past months, I've seen that some windows machines would try to access (with PROPFIND) the same paths which they were accessing via SMB. Just to be clear, someone issuing a

PROPFIND /share/directory/file

where I knew that client would access

\\server\share\directory\file

Since WebDAV is not enabled on those directories, the result at the moment is a 405 status (method not allowed).

In the recent weeks, I've seen a surge of PROPFINDs from a few machines; virus-scan didn't detect any problem on them, and they seem to behave normally.

How can I disable the PROPFIND from those machines? Is this a signal of some known problem? How can I further investigate them?

share|improve this question

1 Answer 1

Sounds like you've got Windows clients trying to use WebDAV instead of SMB.

lifting the following from one of my answers a couple months ago:

In Network Connections, Advanced menu -> Advanced Settings, make sure the "Web Client" provider is below the normal options in the provider order.

webclient

Or just disable the Web Client service.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.