Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't access my client's server over ssh even from the console. It looks like it let me in and then trow me out. Here is my session with the verbose option (I've changed my IP with 192.168.0.1):

debug1: Next authentication method: password
root@192.168.0.1's password: 
debug1: Authentication succeeded (password).
Authenticated to 192.168.0.1 ([192.168.0.1]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
Last login: Fri Dec  2 03:26:47 2011 from gateway.web.net
Usage: ipaliases {start|stop|restart|reload}

debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: client_input_channel_req: channel 0 rtype eow@openssh.com reply 0
debug1: channel 0: free: client-session, nchannels 1
Connection to 192.168.0.1 closed.
Transferred: sent 2448, received 2232 bytes, in 0.3 seconds
Bytes per second: sent 9160.2, received 8351.9
debug1: Exit status 1

From a recovery console I mounted my disk and made sure firewall is disabled. Can anyone help me on this? Also, I don't understand what the ipaliases message above means. Thank you.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

It looks like the /etc/profile or root's .bashrc or .bash_profile has an ipaliases command in it, which isn't being called properly (hence the Usage: ... line). Without seeing those files, it's hard to say for sure, but that would be where I would look first.

If you can, log on as another (non-privileged) user, try to run su - to gain root privileges and have a look at the above files for any ipaliases commands.

share|improve this answer
    
You were absolutely right, I have found that ../init.d/ipaliases was called from /etc/bashrc. It should have been called with the 'start' argument. /etc/bashrc was called from .bashrc. Thank you! –  Andrew Dec 2 '11 at 11:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.