Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Currently I have clients hooked up to a server through NFS such that user home folders mount to the clients (if you want more info on that, let me know).

I am trying to set up a shared drive, in which every file and folder can be edited by any user. Therefore, I have this fstab entry:

babbage:/home/Shared    /media/shared   nfs     nolock,rw,dmask=027,fmask=137,relatime  0       0

I used the information (regarding fmask and dmask) from this forum post

http://ubuntuforums.org/showthread.php?t=283131

However, whenever I use any form of *mask, the drive does not mount (I know this because when I remove the *mask, the drive mounts, however with incorrect permissions).

Any ideas how I can solve this issue?

Thank you.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

dmask and fmask are only applicable for FAT and NTFS partitions.

In short, there's no simple way which I can think of to do exactly what you are saying while preserving ownership information. If file ownership information is not important then you could setup the NFS export with the all_squash option (assuming you're using Linux for your NFS server):

/home/Shared *(rw,all_squash)

This would effectively make all file accesses (reads, writes, creates, etc) run as the anonymous user on the NFS server. /home/Shared would need to readable/writable by the anonymous user on your system (probably nfsnobody on Linux), either by setting ownership or by setting world rwx permissions.

share|improve this answer
    
Works exactly how I wanted, thank you! –  Alex Brooks Dec 2 '11 at 21:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.