Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having some problems setting up a host header for a site. I want to create a second website like this using host headers in IIS

Site: masteradmin
Host Header: none
XXX.XXX.45.28

Site: betamasteradmin
Host Header: betamasteradmin 
XXX.XXX.45.28 

When I try and run my app i get a 504. Here is the result of the nslookup for betamasteradmin

Server: it.example.com
Address: XXX.XXX.44.40

Name: masteradmin.it.example.com
Address: XXX.XXX.45.28
Aliases: betamasteradmin.it.example.com
share|improve this question
    
FYI, please use the example.com and example.org domains for examples as per RFC 2606 (tools.ietf.org/html/rfc2606), unless you are the owner of acme.com of course. –  slillibri Dec 2 '11 at 22:15
add comment

1 Answer

up vote 1 down vote accepted

Try adding another host header with the full "betamasteradmin.it.acme.com" and try that address in the browser, presuming it resolves to the server XXX.XXX.45.28

Also, try adding and entry to the server's local DNS in the hosts file c:\windows\system32\drivers\etc\hosts to associate betamasteradmin with 127.0.0.1 - that way you can open a web browser on the server, and enter "betamasteradmin" as the url, and this should work. Hosts File Wikipedia Entry

That way you can rule out IIS config issues, v.s. network/firewall problems.

share|improve this answer
    
I tried the Host file test to a couple of days ago to ensure IIS was setup right and all worked properly. –  chopps Dec 2 '11 at 22:53
    
I removed all code from the directory the host header points to and added a hellow world ASPX page to test. The page displays this properly. I add the code back into the directory and it gives me 504 errors. –  chopps Dec 2 '11 at 23:02
    
I suggest if your test Hello World ASPX page is returned using the host headers / URL you want, then the host headers /IIS7 are set up okay, and IIS is returning the site correctly. Your 504 errors are probably something else and may warrant a separate post to serverfault? –  Kenny Dec 2 '11 at 23:07
    
Ok..im not totally loosing it. It was a typo in my web.config file. All was setup right. Sighhh. Thanks for the help. –  chopps Dec 2 '11 at 23:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.