Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a problem with an internal web server which we host our intranet on which i'm attempting to connect to using a hostname from dyndns.com (FYI the server is not accessible via IP either). We can access the site the web server is running on internally but not remotely. As far as i can tell there is no issue with port forwarding as i can remotely connect to a web server on my windows machine without any issues through the same router. The intranet server is on an old linux box running Mandrake, here are the details:

cat /proc/version
> Linux version 2.6.8.1-12mdk (quintela@n5.mandrakesoft.com) (gcc version 3.4.1 (Mandrakelinux (Alpha 3.4.1-3mdk)) #1 Fri Oct 1 12:53:41 CEST 2004

Its not possible to update the OS so I need to get this working with this setup. As far as i can tell iptables is not even setup so i don think this is the issue. Not sure where to check for connection errors etc tho. I believe this may have been set up previously using a webmin install if that helps in any way.

If you need any more details then please ask.

Thanks.

share|improve this question
    
Sniff the traffic on the web server using tcpdump, see if anything's coming through. –  womble Jun 30 '09 at 11:18
    
not sure what this is or what i need to do with it, can you provide any more details? –  seengee Jun 30 '09 at 11:24
    
You could also try following the log files as you try to access it (tail -f /wherever/your/log/is). Do this for access_log and error_log, and you should see SOMETHING. If not, then your requests aren't making it to Apache, so you need to start looking elsewhere. –  RainyRat Jun 30 '09 at 11:30
    
I checked these files and no request is being made to apache, where else should i look? –  seengee Jun 30 '09 at 11:31
    
Can you try nslookup and see if the hostname is resolving to appropriate ip address of your webserver. do an "iptables -L" on the server and provide the output. by default the web traffic is stopped unless exempted specifically. –  viky Jun 30 '09 at 11:32

4 Answers 4

up vote 1 down vote accepted

inside webmin > networking > network configuration > network interfaces for some reason the default route had the wrong IP for our router. I changed this to the correct IP and it all works. Thanks for all the help.

share|improve this answer

Does the webserver have different hostnames for internal/external access? If so, make sure it's configured to answer requests with either one; name-based virtual hosting can present this sort of issue, as can any URL-modifying modules like mod_rewrite. Apologies if this next solution is obvious, but is there a firewall configured on the server as well? There may be a rule that allows requests from your LAN, but not the big bad Internet.

share|improve this answer
    
to be honest i'm not sure where to check either of these things, can you advise on this? thanks –  seengee Jun 30 '09 at 11:25
    
Since your clients aren't making it as far as Apache, you don't need to bother about the first part (yet). As for the firewall, I believe it's set up through the Mandrake Control Centre. I haven't actually used it, so I can't give you specifics. –  RainyRat Jun 30 '09 at 12:02
    
web server currently locked away so no GUI access at the moment so will have to try and do this on command line, googling this now –  seengee Jun 30 '09 at 12:06
    
Google tells me that the CLI version of control centre is (a) called "drakconf", and (b) may not be installed by default. –  RainyRat Jun 30 '09 at 13:06
    
drakconf is installed but when i select the firewall option then it just dumps me back to the command line, other options such as services allow me to adjust values so not sure what is wrong here. –  seengee Jun 30 '09 at 13:13

Take a step back. Can you access the server by IP address? If you can you need to ensure the dyndns host name is being correctly resolved. If the IP address is dynamic you may be trying to access the server with a cached address, which may be incorrect.

share|improve this answer
    
hi, sorry but i think the dyndns mention has probably confused things. the server is not remotely accessible by IP either. –  seengee Jun 30 '09 at 11:27

Some ISPs block any incoming transmission on port 80 (one such example would be Videotron in Canada). Try listening on an other port such as 8002 (above 1024, not 8080) and see if you can connect.

share|improve this answer
    
I am able to connect to an apache web server on my local windows machine though. however, as soon as i change the IP to forward port 80 traffic to the linux server thats when the page refuses to load and nothing reaches apache –  seengee Jun 30 '09 at 13:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.