Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 2 Windows 2008 VM domain controllers with DNS Server that have 2 interfaces, a public ip and a private ip. The DNS Servers are being used to resolve queries for a public .com domain. The DNS servers respond correctly and the servers appear to be running correctly.

The problem is that when I use nslookup to query the servers (from the public network), both the public and the private IP addresses are being returned. I want to set it so that only the public IP is being returned on the public interface, and only the private ip is being returned on the private interface.

EDIT: It seems to switch ordering sometimes. When I use NSLOOKUP sometimes I get back the public ip first and other times I get the private ip first. At all times I get both IP addresses back. When a client sees the private ip first it attempts to use the private ip to connect to the server. I cannot use a split-brain dns configuration because both the internal and external domains are the same (because it is one domain). This configuration cannot be changed. There are no users on the internal network. This is used only to connect other servers to the domain and provide fast DNS resolution for internal services running on those servers.

I think my question is short is: How do I add 2 static addresses to the domain something.mydomain.com and have the external address show up for external network users and the internal address show up for internal users.

share|improve this question
    
Okay clarification question: What are you querying? So if you have DC1.YOURDOMAIN.COM it's returning 192.168.1.1 and 1.2.3.4? Or are you querying NS1.YOURDOMAIN.COM and it's giving you both IP Addresses? –  Driftpeasant Dec 2 '11 at 23:08
    
I am queying DC1.YOURDOMAIN.COM –  user61925 Dec 3 '11 at 19:42
add comment

1 Answer 1

What you are looking for is split brain DNS See this article for setup details

share|improve this answer
    
Nope, it's not split brain. The ISP DNS Servers are getting the internal ip address sometimes and the external one other times. –  user61925 Dec 3 '11 at 19:47
    
The article posted gave me the idea to uncheck the create ptr record for the entry and so far it works. –  user61925 Dec 3 '11 at 19:52
    
Nope didn't work. –  user61925 Feb 13 '12 at 22:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.