Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a catch 22 trying to:

   # apt-get update
   [... good lines omitted]
   W: GPG error: lenny-backports Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY AED4B06F473041FA
   W: GPG error: stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY AED4B06F473041FA
   W: GPG error: lenny Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY AED4B06F473041FA

At it notes the NO_PUBKEY issue "means the archive has begun to be signed by a new key, which your system does not know about ... and once the system is fed the new key (by upgrading the debian-archive-keyring package), the warning will go away"

OK, but perversely:

   apt-get install debian-archive-keyring 

gives me:

   WARNING: The following packages cannot be authenticated!

and the solution for that is to do an apt-get update

There's a hole in the bucket, dear 'liza.

Can anyone break the cycle for me?


Note: my /etc/apt/sources.list is:

    deb lenny main contrib non-free
    deb stable main contrib non-free
    deb lenny/updates main contrib non-free
    deb lenny-backports main contrib non-free
share|improve this question
If you want to stick with lenny, then you should replace stable with lenny on the Your current sources.list is probably going to result in a broken system. If you want to upgrade to squeeze, then you should replace all the stable/lenny references, and use squeeze. – Zoredache Dec 3 '11 at 6:05
up vote 12 down vote accepted

Can anyone break the cycle for me?

You are basically just experiencing the standard bootstrapping problem for public key cryptography.

There are many places you can download the public keys for the various archives, but frequently they are not provided over HTTPS, and any checksum files are delivered from the same location.

That wiki link you provided links off to which has provides a copy of the keys you can download over SSL. The problem of course is that the cert for is signed by, which is not distributed with the most common web browsers.

You basically just have to find a way to get a copy of debian-archive-keyring, or the current key from system that you trust, and the install it onto your system. If you are really paranoid, you might have to grab a copy of the archive, and have someone else grab a copy from another mirror on a different computer over a different network. Then compare the checksums.

If you are not extremely paranoid, or in a high security environment, then just let apt-get install debian-archive-keyring install, and ignore the warning.

It would take a lot of effort for someone to setup a MITM between you and the some random mirror. Once they did that, they would have to build their own custom debian-archive-keyring package including their evil key in addition to the standard keys. Then they would have to rebuild some packages to force you to install something evil onto your system. The effort involved would not be trivial.

Debian generally does a pretty good job adding keys that will be used to sign the packages in the future to the debian-archive-keyring package. That is one package, that you really want to keep up-to-date. That way, you will key the keys installed before they are used for signing things, and you won't have this problem in the future.

share|improve this answer
Yeah, Chrome gave me a big fat alert on account of the SSL cert signer not being trusted. Sigh. – David Bullock Dec 3 '11 at 6:00
PS.FYI. The current fingerprint I have for the squeeze signing key is 0E4E DE2C 7F3E 1FC0 D033 800E 6448 1591 B983 21F9 and lenny is 7F5A 4445 4C72 4A65 CBCD 4FB1 4D27 0D06 F425 84E6. – Zoredache Dec 3 '11 at 6:10
Well, my hypothetical enemies are influential, so it's no big deal that the SSL certificate for is not signed by one of the compromised CA's that my browser trusts out of the box. So I got Moxie Marlinspike's Convergence plugin for Firefox. At least I think I did - he didn't trouble to sign the add-on I installed, and it crashed Firefox when I installed it. I have no idea if the default notary servers are reliable, but they seem to agree that the key website is the same one I'm looking at. But probably my enemies already compromised Debian. So heck, I'm going with it. – David Bullock Dec 3 '11 at 6:14
Thanks for the fingerprint. Somehow, rightly or wrongly, I trust someone who gives up their time to help a stranger. – David Bullock Dec 3 '11 at 6:15
Aaaaugh, can anybody provide me with a link to a secure place to download Debian CD signing keys? I am extremely paranoid. Also annoyed, since you'd think they'd AT LEAST use SSL on the page they gave you the keys, if you're gonna be bothering to check them at all. – Erhannis Oct 25 '13 at 5:03

Your problem is that you didn't install debian-keyring as well. Simply run the following:

apt-get install debian-keyring
apt-get install debian-archive-keyring

That's it.

share|improve this answer
I can confirm this works – The Sexiest Man in Jamaica Oct 8 '15 at 12:30

Two things:

  1. Your sources.list file may be incorrect; are you sure those are the right lines for those repos?

  2. You'll have to manually locate the Release.gpg files on those repos and update the keyring:

wget -q -O -|apt-key add -

You might be playing with fire by mixing lenny with the stable repo

share|improve this answer
I'm not sure about #1. I was following instructions at but the line "deb lenny-backports main contrib non-free" was giving download errors, so blindly following I changed it to "deb squeeze-backports main". Now I have it as "deb lenny-backports main contrib non-free" ... is that better ? (I hate playing with fire). Still get 'NO_PUBKEY' tho, so will do your #2. – David Bullock Dec 3 '11 at 5:50

Debian - Apt-get : NO_PUBKEY / GPG error

In computers based on a Debian operating system that uses Linux kernel, error messages may come up like 'NO_PUBKEY'.This happens while using the Apt-Get command line tool and this error is associated with the tool's update feature. The new feature in the Apt-Get package management tool guarantees the authenticity of the server before updating the Debian OS. That's why the error 'NO_PUBKEY' pops up. This problem can be solved by keying in the appropriate commands.

Simply type the following commands, taking care to replace the number below with that of the key that was displayed in the error message:

gpg --keyserver --recv-key  AED4B06F473041FA      
gpg -a --export AED4B06F473041FA | sudo apt-key add -
share|improve this answer
I have experimented above solution and this worked for me. Solved the issue. – Chaminda Bandara Mar 12 at 12:37
apt-key adv --keyserver --recv-keys YOUR_KEY
share|improve this answer

The right thing to do is to not worry about getting the key to your machine securely, but being able to accurately check your trust path to the key once you have it on your machine. This means that you want to find a chain of signatures where your gpg key was used to sign someone's key that was used to sign someone's key... so that you eventually find someone that signed the archive key.

This would obviously be tedious if you were to try to do this by hand if you are more than a couple of steps away from the key. wotsap is a package which will help you discover paths from your key to the keys of the people that have directly signed the archive key.

This all is predicated on you having a gpg key and participating in gpg keysigning, which is absolutely essential if you want to really do this correctly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.