Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried to install PHP 5.3.8 on Windows 7 with IIS 7.5. When I browse to a PHP file, regardless of its content (e.g. empty, a simple print, a call to phpinfo()) I always get this message:

Fatal error: Unknown: Failed opening required '-' (include_path='.;c:\php\ext') in Unknown on line 0
PHP Fatal error:  Unknown: Failed opening required '-' (include_path='.;c:\php\ext') in Unknown on line 0

My PHP scripts don't use any includes. I tried to setup PHP manually in IIS as FastCGI, then I also tried to uninstall PHP and reinstall it, asking to install as FastGI in IIS with the same result.

What am I doing wrong?

share|improve this question
add comment

2 Answers

It means PHP could not scan the directory - or C:\php\ext doesn't exist.

You can rem that line out completely in your php.ini file

share|improve this answer
add comment

I found out it was related to PHP that was mapped in IIS both as CgiModule and as FastCgiModule. I removed the CGI entry and the error disappeared.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.