Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I use gvim 7.2 script dev and other admin work on a Windows XP laptop and it has picked my network share as the location of the _viminfo. This is problematic because it takes a long time for vim to start. Is there a way to change the location of _viminfo file with out modifying my environment.

share|improve this question
add comment

3 Answers

up vote 6 down vote accepted

Use the viminfo option to set the location of your _viminfo. eg

:set viminfo=nC:\\_viminfo

More information is available from Vim's online help ...

:help viminfo
share|improve this answer
    
That sort of worked. I had to add the value for the ' char, not sure why but it worked. –  bkoch Jun 30 '09 at 13:43
    
Yeah, not quite. Edit "C:\Program Files (x86)\Vim_vimrc" and add "set viminfo+=nc:\_viminfo". That seems to have worked. –  C Susi Feb 24 '11 at 4:31
1  
It seems that the + adds on to the default value and (as the above commenter mentioned) you need the ' value so I am guessing it is required (probably mentioned in the docs somewhere). So this also worked "set viminfo='100,nc:\_viminfo" –  C Susi Feb 24 '11 at 4:39
add comment

The $HOME on your login mapped to the network drive is probably causing this.

The easiest way to override this it with an alias that makes vim pick a specific viminfo file.

vim -i _viminfo

However, if you choose C:\ as the path for your viminfo file on a shared machine, the next person trying the same trick may pickup your viminfo file. So, it might be prudent to use,

vim -i _vim-yourname

Finally, to get this working on your machine, you can make a shortcut to vim that has the -i setting defined in it.

share|improve this answer
add comment

if you are on windows, simplest thing to do is use setlocal, endlocal and set your home drive to something else in between.

for example, edit your C:\Windows\vim.bat

at top, add line

setlocal
REM then set your home drive to something local like C: or D
set HOMEDRIVE=D:

REM at bottom final line should be:
endlocal
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.