Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running the mysql with a max_allowed_packet of 32 M (33554432). As I want to dynamically allocate 126M I have gone for the below option

set GLOBAL max_allowed_packet=132120576;

But the show variables like '%max_allowed_packet%'; still Shows 32M only with the already logged mysql sessions but the new sessions are reflected with the new value.

max_allowed_packet                      | 33554432 

Issue Details : While restoring the dump file, I can see the source operation is hanging hence I gone for the above option but still it is in the same state. Can I dynamically do any changes and solve the issue ?

share|improve this question

1 Answer 1

You can set max_allowed_packet from the client, it is not enforced at the server in that regard, the server variable is really meant for replication. The max is 1GB.

mysql --max_allowed_packet=512M -p < my_big_dump.sql
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.