Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed .Net 1.1 on a Windows Server 2008 (which already had .NET 4 installed). Afterwards, I started getting the following error:

HTTP Error 500.0 - Internal Server Error Calling LoadLibraryEx on ISAPI filter
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\\aspnet_filter.dll" failed 

I have tried running aspnet_regiis without success. I have also tried the suggestions by Rick Strahl but to no avail.

I have also removed .NET 4.0.30319 using the cleanup tool. When I reinstalled it, The error was still there. I have already removed 1.1 but still i get that error. Please help.

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

Resolved by adding a new asp.net site and assigning a new application pool.

share|improve this answer
add comment

This fixed the issue for me as re-creating the website didn't work:

http://www.west-wind.com/weblog/posts/2011/Apr/04/Error-on-64-Bit-Install-of-IIS-LoadLibraryEx-failed-on-aspnetfilterdll

In summary, setting the app pools Enable 32-Bit Applications to true will fix the issue.

share|improve this answer
    
Hi, just posting links is frowned on here as this information may disappear. Any chance you could edit your answer with a summary - it doesn't have to be hugely detailed, so long as it's enough to point people in the right direction if the link goes. –  Dan Jun 16 '12 at 16:08
    
Note that in the IIS Manager for IIS 7.5 I was able to select the problematic ASP.NET_4.0.30319.0 ISAPI filter, click the "Edit..." action on the right, and change "Framework" to "Framework64" directly in the editor that popped up. Fixed it for me! –  JoshL Mar 1 '13 at 23:24
add comment

From error one can observe that path mentioned was incorrect(Extra slash before .dll file). Edit ISAPI filter and edit the path to remove extra slash.

share|improve this answer
    
This fixed the issue for me. I think Microsoft needs to review their code and ensure they either don't include extra slashes in their built-in configuration settings, or else update their tools to treat doubled slashes as single slashes. –  Zarepheth May 24 at 17:14
add comment

The problem is the double backslash.

Go to your server and select "ASAPI Filter" and remove the second backslash from path ;)

Then from blog.clicdata.com:

Get a command prompt in administrator mode and go to C:\Windows\Microsoft .NET\FrameWork64\v4.xxx and run aspnet_regiis -r. This will re-register the right libraries

share|improve this answer
    
Thank you for your solution, but please to try to include the relevant information in your answer and not only the link, because links tend to die. I have edited your answer accordingly but feel free to improve on that. –  HBruijn Jul 10 at 13:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.