Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm managing a mail server that was set up on FreeBSD that runs Postfix and Dovecot. When I type postconf -a, nothing is returned. As I understand it, this command should tell me if SASL is supported by my Postfix install. Since nothing was returned, what do I need to do to give support for outgoing mail?

share|improve this question

4 Answers 4

up vote 2 down vote accepted

If your output is blank, then you have a Postfix server which lacks SASL support at all.

Now you have different options to go from here:

  1. Look if your BSD provides Posfix packages with SASL support. Probably with extension packages?
  2. Compile your own Postfix with SASL support.
  3. Look if you find packages on the Internet that are compatible with your BSD version and that have SASL support compiled in.

As I'm not familiar with FreeBSD at all, I don't know if that what I've found is correct. But according to the Postfix Port the Dovecot SASL is disabled by default and Cyrus SASL is disabled if the SASL2 Port is not installed.

share|improve this answer

You will need to check your main.cf configuration files. The

smtpd_sasl_auth_enable = yes

variable is the one you will need to check. Then in master.cf the service needs to be configured properly.

I am not sure on FreeBSD (RHEL user), but may be easier to copy the dovecot information and do a fresh install.

share|improve this answer
    
I've added that to my main.cf, but postconf still returns nothing. Does this mean I need to recompile postfix? Do I need to use Dovecot to handle outgoing mail? I was planning on going with Cyrus, but whatever has the least downtime is ideal since I don't have a testing server. –  devnill Dec 5 '11 at 20:33

In my Debian postfix, I have the answer 'cyrus dovecot', so you are right your postfix say not have the sasl support. In this case, the outgoing mail support is provided for your networks. Do you compile your postfix ? Then add the sasl support. Else ask your provider to add it in the compilation !

share|improve this answer

If you installed Postfix from ports, it won't have SASL by default. If you do:

cd /usr/ports/mail/postfix
make config

You will see a wide range of SASL options.

Once you've chosen what you want, reinstall the port using:

make deinstall reinstall
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.