Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

First, I have seen http://support.microsoft.com/kb/822447 and gone through the steps (with the exception of the replace string, as that seems like more of a work around than an actual solution).

I couldn't find any .net installed with the exception of KB958488, which I uninstalled and reinstalled after changing the regional settings.

We have two Exchange 2007 servers running on a Windows 2003 server and Windows 2008R2 server. This issue only effects mailboxes running on the Windows 2008R2 server.

As said, I have changed the regional settings to Swedish, made sure it is copied to all accounts, reinstalled the only trace of .net I could find and still have made no progress.

Any help would be hugely appreciated.

Edit: As pointed out this is a little unclear.

Simply put, exchange is adding email addresses as follows:

Ingmar Bergström gets both ingmar.bergstrom@example.com and ingmar.bergstroem@example.com

The "oe" that is replacing "ö" is incorrect and unwanted, it should simply be o (which is the behavior on the other server).

I just realized I pasted the wrong link in the window!

http://support.microsoft.com/kb/948212

share|improve this question
1  
You might want to clarify what you're trying to achieve. Based on what you've written so far we don't actually know what you're trying to do –  Mark Henderson Dec 5 '11 at 23:57
    
It just came to my attention that I did not remove .net 3.5 through "Features" under server manager. Could this be the issue? My service window is rapidly closing so I don't have time to test it right now. –  Stew Dec 5 '11 at 23:57
    
@MarkHenderson Added a bit more info at the bottom. –  Stew Dec 6 '11 at 0:00
    
Much better now. Unfortunately I can't help :( –  Mark Henderson Dec 6 '11 at 1:30
add comment

2 Answers

This seems like a bug to me. Have you tried building another 2k3 server and verified that it affects only 2k8? If so I'd suggest contacting Microsoft.

share|improve this answer
    
Installing another 2003 server isn't really an option, however I could potentially reinstall 2k8 and ensure that the region settings are correct from the outset. It will be a while before I have time for that.... –  Stew Dec 6 '11 at 7:07
add comment

Seems like after changing the regional settings and reinstalling .net the issue is resolved for all new accounts, however not for accounts that have already encountered the issue (which I suppose is best as they have sent out a few emails with the oe address instead of the o address). The issue is resolved enough, as the o address is now the default for all users with ö in the name.

In short, the kb article did fix it, I was just tired and impatient.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.