Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Previously, when using Windows authentication in an IIS application it would use the application pool identity to access the disk files. This meant the ACLs had to know the application pool identity for Read permission, etc. Impersonation is NOT being used here.

An application that has disabled anonymous and enabled Basic and Windows authentication and has Windows authentication configured in the web.config was refusing access to a user (correct credentials) that was configured as "allow" in the web config for a particular directory until I configured that user to have Read permission on the file.

This seemed odd because without impersonation, I was under the impression (and I certainly seem to recall it being the case before) that it would access disk resouces as the Worker Process Identity (a named domain service account in this case, this service account is in IUSR_WPG or whatever the correct name for the worker process group is).

Any ideas why it wants ACLs configured for the specific user instead of the domain service account that is the WPI?

share|improve this question
    
Previously, like when? I'm pretty sure IIS 6 had this behavior, too.. –  Shane Madden Dec 6 '11 at 4:49
    
I recall it doing that only when impersonation was turned on (i.e. windows authentication for the database connection uses the WPI, why would it differ for local disk access). –  Jared Peless Dec 6 '11 at 4:53

1 Answer 1

I believe you have to enable anonymous if you want the application to use the service account. Check out IIS Authentication Article

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.