Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I try many ways, but still doesn't work.

  • MSSQLSERVER is running.
  • SQL Agent is running.
  • SQL Browser is running.

  • TCP/IP is enabled (something else inside it must I change?)

  • Named Pipes is enabled

  • Allow remote connections to this server - checked.

I try connect in VS2010 by Test connection with NAME-NOTEBOOK/MSSQLSERVER or ip_sql_server_machine/MSSQLSERVER

Now I get error

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accesible. Verify that the instance name is correct and sql server allow remote connection. (provider: Named Pipes Provider, error 40 - Could not open a connection to SQL Server)

EDIT

When I try to connect by SQL Management Studio get new error:

login failed. the login is from an untrusted domain and cannot be used with windows authentication. Error: 18452

share|improve this question

migrated from stackoverflow.com Dec 6 '11 at 5:10

This question came from our site for professional and enthusiast programmers.

    
Have you checked firewall configuration on the SQL server? –  Corbin Dec 5 '11 at 9:44
    
How can I check it? –  Saint Dec 5 '11 at 9:48
    
You can try to do a raw telnet and just see if a connection is made. From your comments on marc_s' post though, sounds like it's not a firewall issue. –  Corbin Dec 5 '11 at 10:02
    
@Corbin Can you say, how can I do this? –  Saint Dec 5 '11 at 10:17
    
Go into Control Panel and find the firewall stuff. I don't remember exactly what it's called, but should be somewhere in the network settings. You might just be able to type "firewall" in the search box (if Win Serv 08). You'll need to open whatever port MSSQL is using (and you'll likely want to limit the scope to only LAN addresses, or maybe only the LAN address you want accessing it -- the less access the better). –  Corbin Dec 5 '11 at 10:18
show 4 more comments

1 Answer 1

You have to make sure that you have a Windows user account on the server that runs SQL Server, or have a user in the Active Directory domain that the SQL Server runs in.

Then you have to add your user to the SQL Server, right click Security and add your user. Hit search and type in your username.

This will work even if your server is not in a domain, you just have to make sure your local user name and password is the same as on the server.

Good luck.

// Marius

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.