Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Few days back, I upgraded to openSuse 12.1 from openSuse 11.04 vai online upgrade. Now if try to start apache server as -

 sudo /etc/init.d/apache2 start

it gives error as -

 redirecting to systemctl
 Job failed. See system logs and 'systemctl status' for details

also i checked -

rtdp@linux-vai9:~> systemctl status apache2.service
apache2.service - apache
      Loaded: loaded (/lib/systemd/system/apache2.service; disabled)
      Active: failed since Tue, 06 Dec 2011 13:21:11 +0530; 3min 54s ago
     Process: 2688 ExecStart=/usr/sbin/start_apache2 -D SYSTEMD -k start (code=exited, status=1/FAILURE)
      CGroup: name=systemd:/system/apache2.service

Even if I try stating ngnix, it gives error as -

rtdp@linux-vai9:~> sudo /etc/init.d/nginx start
redirecting to systemctl

and ngnix doesn't start.

What might be causing this. Tried googling but no help. Thanks in advance.

share|improve this question

2 Answers 2

up vote 5 down vote accepted

Start checking the logfile of the apache, especially the error log. Eventually raise the LogLevel directive. You might simply miss an active module, library or dependency for the server to start.

Update: Your problem is caused by the upgrade. Opensuse switched from sysvinit to systemd as you can read here: link. You can read up on the issue in the bugreport: link.

The workaround: is to install the sysvinit-init package. As soon as its install gets acknowledged the removal of the systemd-sysvinit package will be suggested.

share|improve this answer
    
I have updated my question, even ngnix doesn't start. I checked apache error_logs, but it doesn't write anything there. –  rtdp Dec 6 '11 at 9:22
    
Updated my answer to assist in your issue. GL –  Chris Dec 6 '11 at 9:55
    
This worked !!! Awesome !!! many thanks !! –  rtdp Dec 6 '11 at 10:24

try using the server native script apache2ctl or htttpd2

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.