Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

today at 02:20 I noticed that suddenly Munin stopped updating its graphs. It is not showing blank data, the whole graphs are not being updated anymore.

I run CentOs 5.7 (64) and ive installed Munin via yum. All was working, till 02:20.

First thing I did was restart Munin: service munin-node restart.

It restarted without problems or errors, but it still didn't update the graphs.

So I checked out all the log files in: /var/log/munin and apart from munin-node.log non of the files were updated since 02:20.

All that was added to munin-node.log was:

2011/12/06-02:57:19 Server closing! Process Backgrounded 2011/12/06-02:57:20 Munin::Node::Server (type Net::Server::Fork) starting! pid(16603) Using default listen value of 128 Binding to TCP port 4949 on host Setting gid to "0 0"

On every restart I tried after the same message showed up.

I am really clueless to why Munin stopped working all the sudden. Any idea what I can try?

share|improve this question
Is the crontab file still there (/etc/cron.d/munin)? Is cron still running? What happens on that host when you do telnet localhost 4949 and say list? Could you update your question with some of this information? – MadHatter Dec 6 '11 at 9:50
up vote 3 down vote accepted

Make sure that the user which munin is running as has enough permisison to write to .rrd, .png, .html files. There is a question on the Munin FAQ.

share|improve this answer
Ive removed all the .rrd files, and the .html files, restarted it again, and eventually it started working again. – Mr.Boon Dec 6 '11 at 12:17

I once had this problem when one of my servers restarted, runing the command munin-check helped me realize the problem had to do with folder permissions.

Note: Even though I already had a folder /var/www/html/munin/web/monitoring and it has correct permissions set, munin-check complained about not finding that folder, I guess that's what the "this script may be buggy" warning means.

share|improve this answer
You can also run this with the option "--fix-permissions" – Rob Jun 18 '15 at 9:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.