Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a 2008 Server SP1. We're only able to RDP one at a time, if a 2nd user RDP's in the first user gets disconnected. How do we allow for multiple sessions to be connected at the same time? Do we need to install TS?

share|improve this question
    
This is not R2, it is Windows 2008 Std. –  xedgex Dec 6 '11 at 17:42
    
Do you have all admins logging in as the same account? Or did you assign admin accounts for each admin (a far better idea for accountability). –  Multiverse IT Dec 8 '11 at 3:58

4 Answers 4

In order to have more than 2 users at one time on one Windows Server 2008 server using Remote Desktop Services, you must install the Remote Desktop Services role, and purchase the appropriate licensing.

The behavior you're describing occurs when you have USERACCOUNTA and multiple users try to log on to the server as USERACCOUNTA - by default Remote Desktop on 2008 and later allow for one session/account. This includes the console session, BTW. To get around this you uncheck the "restrict each user to a single session" check box in Remote Desktop Session Host Configuration (instructions from Microsoft here).

share|improve this answer

In addition to Paul's answer you can allow two user's to connect to your Windows 2008 (and Windows 2008 R2) server at the same time by unchecking the "Restrict each user to a single session" setting in the Terminal Services configuration MMC:

enter image description here

To get there using the UI do:

Control Panel -> 
    Administrative Tools -> 
        Terminal Services -> 
            Terminal Services Configuration

Once upon a time (up to Windows 2003 Server) you could have three separate sessions but sadly Microsoft decided two was plenty for Windows 2008 onwards.

share|improve this answer

You can change the default behavior to allow multiple sessions.

  1. Start regedit
  2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer
  3. If the fSingleSessionPerUser value doesn’t exist, create a new DWORD value named fSingleSessionPerUser
  4. Open the fSingleSessionPerUser value. The possible values for this setting are as follows: 0×0 Allow multiple sessions per user 0×1 Force each user to a single session
share|improve this answer

Check to see that your users aren't connecting to the console. That will cause the second user to bump the other one off. Otherwise you should be able to have two logged in at the same time via rdp.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.