Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I try to setup kohana 3 project as virtual host.

Config:

<VirtualHost *:80>
  DocumentRoot "D:/Devel/matysart/matysart_dev1"
  ServerName matysart-one.local
  ServerAlias www.matysart-one.local
  DirectoryIndex index.php
</VirtualHost>

Error (403):

[client 127.0.0.1] client denied by server configuration: D:/Devel/matysart/matysart_dev1/

.htaccess

# Turn on URL rewriting
RewriteEngine On

# Installation directory
RewriteBase /

# Protect hidden files from being viewed
<Files .*>
    Order Deny,Allow
    Deny From All
</Files>

# Protect application and system files from being viewed
RewriteRule ^(?:application|modules|system)\b.* index.php/$0 [L]

# Allow any files or directories that exist to be displayed directly
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

# Rewrite all other URLs to index.php/URL
RewriteRule .* index.php/$0 [PT]

Could somebody help?

share|improve this question
    
Do you have a .htaccess in that location? Does the .htaccess (if present) or your Apache configuration conatain something like Order deny,allow Deny from all or Deny from 127.0.0.1? –  Lukas Dec 7 '11 at 12:25
    
yes it has, it standard kohana htaccess –  drupality Dec 7 '11 at 13:32

1 Answer 1

up vote 0 down vote accepted

Try setting up a Directory container like this within your VirtualHost brackets

<Directory "D:/Devel/matysart/matysart_dev1">
   Options Indexes FollowSymLinks MultiViews 
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.