Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am testing redirects using curl on my localhost. When I run this command:

$curl ""

I get this output:

<title>302 Found</title>
<p>The document has moved <a href=";tt=192">here</a>.</p>
<address>Apache/2.2.17 (Fedora) Server at Port 80</address>

Now if I run;tt=192" I get to me desired destination. So basically all I want to do is turn off the 302 error and redirect to the page it is supposed to redirect to.

share|improve this question
up vote 1 down vote accepted

curl doesn't follow redirects by default, but this isn't your web server's problem; HTTP clients are responsible for implementing handling of redirect responses.

Add the -L flag:

curl -L ""
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.