Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Tried this:

yum install php-soap


No package php-soap available.

Then tried this:

yum --enablerepo=centosplus install php-soap

Still same sh!t. Tried this:

rpm -Uvh

Still no luck. Guys, where's the repo that contains the needed package?

The server is at btw...

share|improve this question
what varsion of centos is it? Did you try yum search soap or yum search php-soap? what version of php are you using? – B14D3 Dec 7 '11 at 22:26
yum repolist? ls /etc/yum.repos.d/? rpm -qa | grep php? – quanta Dec 8 '11 at 10:07
Did you fix this yet? Same issue here, PHP 5.3.3 Centos 6 – user174961 May 23 '13 at 10:12

firstly open /etc/yum.conf file. Find exclude line and erase php* command, then, save the file.

Then, 'yum install php-soap' command should work. comment by Mehmet

Worked for me :)

share|improve this answer

I think that remi repo is what you are looking for.

Remi Dependency on CentOS 6 and Red Hat (RHEL) 6

rpm -Uvh

CentOS 6 and Red Hat (RHEL) 6

rpm -Uvh

Remi Dependency on CentOS 5 and Red Hat (RHEL) 5

rpm -Uvh

CentOS 5 and Red Hat (RHEL) 5

rpm -Uvh
share|improve this answer
after run this command find -name in root folder i see this is soap path ./usr/lib64/php/modules/ i set this line extension='./usr/lib64/php/modules/' /etc/php.ini file and restart httpd services in cent os 6. but still it couldn't enable soap service. any idea? – Maulik patel Apr 27 at 14:01
remove dot at the begining "extension='/usr/lib64/php/modules/'" after that check with php -m if the module is loaded – B14D3 May 10 at 11:11

I have it in epel and rpmforge repos on CentOS 5. Did you try with --enablerepo:

yum --enablerepo=epel install php-soap
share|improve this answer
Still says No package php-soap available. It's unbelieveable! But appreciate your answer btw. – Dmitry Dec 7 '11 at 22:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.