Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I been googling, and all I can find is that this error may happen when you post to an html file. In my setup I have a rewrite rule, that basically hides the index.php from the url, and I for the longest time I thought it had something to do with that. Get works fine.

Method Not Allowed

POST request is not allowed for the URL /post.php

Here is my setup:

Debian squeeze / AMD64

nginx version: nginx/1.1.8

PHP 5.3.3-7+squeeze3 with Suhosin-Patch (cli) (built: Jun 28 2011 08:24:40) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I just solved this problem my self!

I installed lighttpd, and got the same error again with lighttpd as well. I was looking at all the wrong places because the error 405 is a webserver error.

However, I just started using a new php framework called fatfree F3, and the error is being generated by this framework when you use GET like so:

F3::route('GET /autho/idreply', 'auth.php');

The GET means that the framework is expecting only GET variables and will reject POST variables.

With a server error 405, that is!

So changing that to, following did the trick:

F3::route('POST /auth/oidreply', 'auth.php');  

And you can even let the framework accept both or either with this command;

F3::route('GET|POST /auth/oidreply', 'auth.php');  
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.