Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I wonder if anyone has come across this before? I have checked all Internet Explorer settings.

I have put on a custom security level enabling Active X controls (which is a risk I know) but yet when i try to access my CCTV cameras, I am still getting this error.

I wondered if anyone had seen this error before?

"Windows has blocked this software because it cant verify the publisher"

share|improve this question

closed as not a real question by MDMarra, Scott Pack, mailq, Ward, jscott Dec 11 '11 at 0:55

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

Internet Explorer by default won't allow anything signed with an invalid certificate. You must manually go in and change the setting in the security settings "Initialize and script ActiveX controls not marked as safe for scripting" and either change it to prompt... or to enabled (very insecure)
Alternatively, if you can get the certificate for the activex control... and then add it to your root certificate authorities in the local machine... it would be able to identify the certificate as being signed.

Basically... the person who created the activex control either A) is using a bogus certificiate to sign his programs... or B) had a valid certificate but let it expire or it was revoked.

On a second though... Have you tried using a non-activex enabled browser? many programs like that have some detection built-in that will try activex... then fail-back to java or some such.

share|improve this answer

I have had this happen and simply right clicking the .exe from the Explorer Window and selecting 'Unblock' solved it.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.