Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i screwed up with compiz and tried to enable the "blur windows effect" my computer auto logs onto my name so I never see the login screen itself. because of the blur windows effect, my desktop looks all pretty until i try to do anything. Then it just turns black. so my question is this: "Is there any way to disable the effect or all the effects in compiz through the recovery terminal? i have tried typing "startx" in the recovery terminal but when it pulls up the default desktop my mouse and keyboard stops working so I can't do anythng anyways. any help?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Try renaming the .compiz.save file in your home directory, if there is one, then restarting X.

Also, once you're logged in, try hitting CTRL-ALT-F2 to get to a terminal, log in, then "killall compiz" and "killall compiz.real" to kill the compiz process. CTRL-ALT-F7 should get you back to X, where you should now be able to disable the effects.

share|improve this answer

Ctrl+Alt+F1 (switch to another terminal)

Log in (darn security)

metacity --replace (replace compiz with metacity as the window manager)

Ctrl+Alt+F7 (Switch back to xwindows)

share|improve this answer

Assuming you have "flat-file Configuration Backend" selected to save your preferences and you are using the default profile, you could also modify the line in ~/.config/compiz/compizconfig/Default.ini that says "as_active_plugins" and remove blur from that line. Then when compiz reloads on a reboot it won't load that plugin anymore.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.