Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I had to remove cups from my machine to do some tests. I juste removed it with apt-get purge cups but now I can't install it again, so I can't print. I have never seen such an error, can someone give me some explanations about what's happening ? (I mostly want to learn and understand my error, but I googled it up and there is so much different case. I'm running Ubuntu 10.04).

When I try to install it with apt-get install cups, I get this outcome :

root@pc-desktop:/home/pc# apt-get install cups
Reading package lists... Done
Building dependency tree        
Reading state information... Done
cups is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up cups (1.4.3-1ubuntu1.5) ...
update-rc.d: warning: /etc/init.d/cups missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
/usr/sbin/cupsd: symbol lookup error: /usr/sbin/cupsd: undefined symbol: _httpReadGNUTLS
cups: unable to start scheduler.
invoke-rc.d: initscript cups, action "start" failed.
dpkg: error processing cups (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of ghostscript-cups:
ghostscript-cups depends on cups; however:
Package cups is not configured yet.
dpkg: error processing ghostscript-cups (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cups-driver-gutenprint:
cups-driver-gutenprint depends on cups (>= 1.3.0); however:
Package cups is not configured yet.
cups-driver-gutenprint depends on ghostscript-cups; however:
Package ghostscript-cups is not configured yet.
dpkg: error processing cups-driver-gutenprint (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
cups
ghostscript-cups
cups-driver-gutenprint
E: Sub-process /usr/bin/dpkg returned an error code (1) 

And I have a prompt again.

Does somebody have any clue ? I really don't know where I should begin to search.
Thank you very much in advance.
Patrick.

share|improve this question
    
what happens after an apt-get -f install ? –  pna Dec 8 '11 at 17:17
    
Well, nothing special unfortunately. I did remove cups, and tried with the force option but no, it won't instal... pastebin.com/pjJazH45 –  PatrickCUDO Dec 8 '11 at 17:22

4 Answers 4

hmmm try an autoremove after the install:

sudo apt-get purge cups && sudo apt-get autoremove
sudo apt-get update && sudo apt-get install cups
share|improve this answer
    
Hello. Thank you for your hint, I thought it will work, but no :-( I rebooted my system, but no it won't even open the Printing tool in System => Administration. It just does nothing, and there is still no way to print... pastebin.com/Yh0Nijje –  PatrickCUDO Dec 8 '11 at 17:46

How about

apt-get install --reinstall cups
share|improve this answer
    
I have the same kind of error. –  PatrickCUDO Dec 8 '11 at 17:06
    
pastebin.com/ZWscAxM4 Here is the outcome with the --reinstall flag. I have tried it already. And I reaally don't know what's going on... –  PatrickCUDO Dec 8 '11 at 17:07

If your CUPS is still installed, it sounds like your initscript is borked. Did you manually modify your CUPS startup script or the LSB headers?

share|improve this answer
    
Hello. Yes I have uninstalled the 1.4.4 version and installed a previous version (1.3.8) for testing purpose. Now I have removed the 1.3.8 one and want to install the 1.4.4 back, but no it won't. I should have used a testing environnement. :-( –  PatrickCUDO Dec 9 '11 at 13:12
    
But have you modified your LSB headers? The only time I've ever run into this problem is when somebody got creative with the LSB headers because he wanted to add new functionality to the 'service' command. –  Magellan Dec 9 '11 at 17:00
    
Nope, I haven't touched the LSB headers. I don't even know what those are. I'm going to google it. The less I play with my working desktop machine, the better it will be. I can't print now because of an error I don't understand, and I'd rather fix it than doing a new and clean install. Thanks for helping me out, Adrian. –  PatrickCUDO Dec 9 '11 at 17:07
up vote -1 down vote accepted

Reinstalling Ubuntu did it. A bit rough.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.