Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

all.

After deleting a few domain-based non-roaming user profiles manually from C:\Users (including my own), I kept getting the following error upon login:

"The User Profile Service failed the logon. User profile cannot be loaded”

I tried to delete the SID from the registry as well as the GUID registry key used to cache the SID to no avail. After using procmon to find out what it wants, I see that it's referring to a few folders:

C:\users[myaccount] C:\users[myaccount].[domain_forest_name] C:\users\Default (doesn't exist on another 2008 server I can log into)

Since the problem happened with another user, I tried restoring his profile back to before I deleted it and he was also unable to log in even after following these steps.

I'm at a loss on what to do here. Every piece of info I've searched keeps referring to the SID deletion method, which clearly isn't working for me.

Has anyone run into this problem and/or have suggestions? Much appreciated!

share|improve this question
1  
Deleting profiles in that manner is the wrong way to do it. There are all kinds of registry keys still associated with the profile. Unfortunately, I don't know how to actually fix this once it breaks. –  MDMarra Dec 8 '11 at 23:07
2  
What SID did you try to delete? The profile entry in the ProFileList key? If you removed that key, it's likely a permissions issue (on C: or C:\Users). –  Chris S Dec 8 '11 at 23:08
add comment

3 Answers

Try deleting the profile from the System properties Advanced tab (which is the correct way to delete user profiles). The profile may show up as Account Unknown, so if you see any profiles listed as Account Unknown, delete them and see if that corrects the issue.

share|improve this answer
add comment

When I got the "User profile could not be loaded" message, and got logged in with a temporary profile, I noticed that my profile directory (C:\users\) was missing. I recreated it and left it empty. It then showed up with a status of "Backup" in Advanced system settings; I deleted it from there, and the next time I logged back in, a new one was created for me, with the correct status (i.e., "Local").

share|improve this answer
add comment

Turning UAC off fixed the problem.

share|improve this answer
1  
Glad you resolved the issue. Please be sure to mark your answer as "accepted" when you are able. –  jscott Jul 17 '12 at 2:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.