Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have application it supports SOCKS4 proxy support and we would like to test it. So we have installed dante in SUSE and it is configured for SOCKS5 by default. Is there any option where we can enable SOCKS4 support?

Thanks in Advance

share|improve this question

1 Answer 1

up vote 1 down vote accepted

According to the man sockd.conf, by default, it supports both of v4 and v5. But you can specify only v4 by using proxyprotocol option, something like this:

route {
    from: 0.0.0.0/0 to: 0.0.0.0/0 via: 127.0.0.1 port = 1080 
    protocol: tcp
    proxyprotocol: socks_v4
    command: connect
    method: none
}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.