Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We recently upgraded from W2K3/IIS6 to W2K8/IIS7 and have been having problems with our SSL Certificate (Thawte 123 SSL certificate) ceasing to work after rebooting.

Initially, the intermediate certificates would stop working and we could repair the problem by reinstalling all of them after the reboot (annoying, but not the end of the world). Unfortunately, this is no longer working. The certificate chain has been doublechecked by several tools and people with decent knowledge but no one has been able to identify the cause of the problem.

The bindings in IIS have been checked as well

The cert itself is also still valid.

NOTE 1: I have seen THIS question which seems to be very similar, but there is no satisfactory answer in that post and it's a year old so not likely to get one any time soon. NOTE 2: I'm asking this on behalf of a co-worker so won't be able to provide instant feedback to any questions/suggestions but I will pass it on.

The url is:

http://www.flirtalike.com / https://www.flirtalike.com

Screenshots:

enter image description here enter image description here enter image description here enter image description here

share|improve this question
up vote 0 down vote accepted

We found a solution from HERE:

After the machine is rebooted, go to the IIS Manager and bring up the Bindings… window for the website in question. Then, select “https”, click on “Edit” then click “Ok” without making any changes to the settings. After doing this, browsing to https:// should now be successful.

We still need to do this after every reboot unfortunately, but at least we have working SSL!

share|improve this answer
    
Gosh, that sucks. Have you opened a support ticket with Microsoft for that? This smells like a bug. Worth a hotfix. I would put it Prio A - a power failure - reboot - renders servers unusable, possibly at a BAD time. Cries for a hotfix. – TomTom Jun 20 '12 at 7:46
    
Hehe, you're probably right @TomTom - however this happened over a year ago and we haven't been using that server for at least 6 months of that year. In other words, it's completely impossible for us to reproduce. Next time... – Zac May 7 '13 at 20:40
    
Oh right, you asked that in 2012. I guess that happens when you review your profile once per year because you don't spend much time on Serverfault... – Zac May 7 '13 at 20:46

Install correct intermediate certificate into intermediate store according https://search.thawte.com/support/ssl-digital-certificates/index?page=content&id=SO15171&actp=search&viewlocale=en_US&searchid=1282614432001

share|improve this answer
1  
Thanks for the reply Pavel. Unfortunately, we won't be able to try this solution - my colleague tells me that we ended up getting an alternative certificate which no longer gives us any problems. – Zac Jun 20 '12 at 10:13

we have noticed same issue. After each server restart the SSL certificates are removed. The warning in EventLog appear on our machines right after start of TrendMicro OfficeScan. But even uninstalling the virus scanner did not changed anything. The problem persist after each restart.

Our research end with confirmation, that all settings are done correct in registry and "applicationHost.config" at "C:\Windows\System32\inetsrv\config\". But after restart this file is modified and teh certificate assignment is removed. (perhaps someone can find from here real reason.

Our conclusion was now to make workaround. With this instruction we created PowerShell script to assign the certificate again. http://www.iis.net/learn/manage/powershell/powershell-snap-in-configuring-ssl-with-the-iis-powershell-snap-in This is then set on computer start to be executed automatically (in elevated mode!).

Import-Module WebAdministration;set-location IIS:\
cd IIS:\SslBindings
get-item "cert:\LocalMachine\webHosting\*" | new-item 0.0.0.0!443

Depending on your certificate store you need to adapt the location. In case you have mutliple certificates you need to add a "-filter" to select the right one. (Above sample is for setting the certificate on port 443 for all IPs "*" .)

Hope this helps other people running in this stupid issue. We got this on "Win2012 Server" with IIS8 in year 2016(!) - still same problem persist!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.