Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

i have a web app on the server that sends emails with aspemail from persists

today it stopped and i get error Winsock error 11004 (0x2AFC) occurred.

if i try to ping the host server it won't work, if i try to ping it's ip it works so if i change the host server for the mail send to gmail's ip - it works...

i have tried the reset of the winsock, didn't work

what can be done to fix this?

share|improve this question

1 Answer 1

You might have to redirect the DNS request via WinSock proxy. See also:

share|improve this answer
but it worked until 2 days ago – Y.G.J Dec 9 '11 at 14:46
Try to find out why DNS resolving is not working trough WinSock. – Mircea Vutcovici Dec 9 '11 at 14:52
Do you use a WinSock proxy? if not, then try to see if you DNS server is reachable from your server. Use: nslookup, then try nslookup If the second one is returning the IP of the SMTP server from Google, then you need to update the DNS server configuration for your windows server – Mircea Vutcovici Dec 9 '11 at 14:54
never mind... my stupid friend add a local security policy. add assign to block ip and it blocked all ips – Y.G.J Dec 9 '11 at 15:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.