Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm on CentOS 5 with Apache. I'm trying to make this directory get a 403 error and it still continues to show the index of.

Here's the .htaccess file. I gave it 644 permissions:

Options –Indexes

Thanks!

share|improve this question
    
May I ask why my question was downvoted? I'm happy to supply more information at request. I don't really know what information I'd supply though. Let me know. Thanks. –  user1062058 Dec 9 '11 at 18:47
    
Do you have root access on the box? or can you request that changes be made to the apache configuration? –  stew Dec 9 '11 at 19:00
    
full root access –  user1062058 Dec 9 '11 at 19:11
    
if you can edit the apache configuration, then you should NOT be using .htaccess files. just put the configuration you need into the server config. Changing stuff in .htaccess is disabled by default because it opens up security problems and can have a big performance hit –  stew Dec 9 '11 at 19:14

2 Answers 2

up vote 1 down vote accepted

Chances are the main config for that site doesn't have -/+Indexes allowed in it's AllowOverride directive

share|improve this answer
    
Thanks for the responce. Should it be set to this: AllowOverride None –  user1062058 Dec 9 '11 at 18:58
    
This is what it currently is: <Directory "/var/www/error"> AllowOverride None Options IncludesNoExec AddOutputFilter Includes html Order allow,deny Allow from all LanguagePriority en es de fr ForceLanguagePriority Prefer Fallback </Directory> –  user1062058 Dec 9 '11 at 19:02
    
That's your problem :) AllowOverride Indexes –  thinice Dec 9 '11 at 19:02
    
Do I change the AllowOverride in <Directory "/var/www/error"> or <Directory /> ? –  user1062058 Dec 9 '11 at 19:07

The directory listing could be cached in your browser. Try clearing your browser cache, or pressing Shift+Reload.

share|improve this answer
    
I just tried that, no luck. Thanks for the suggestion though, didn't think of that. –  user1062058 Dec 9 '11 at 18:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.