Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server with minimal installation of CentOS6 64bit (minimal option from the installer). The bonding driver does not seem to work correctly. The output from /proc/net/bonding/bond0 is:

Bonding Mode: fault-tolerance (active-backup)
Primary Slave: None
Currently Active Slave: None
MII Status: down
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

The as you can see there are no interfaces listed as salves. The bond driver options were configured in /etc/modprobe.d/bonding.conf as:

alias bond0 bonding
options bond0 mode=1 primary=eth0 miimon=100

Interfaces eth0 and eth4 are configured as such:

DEVICE="eth0"
MASTER="bond0"
SLAVE="yes"
HWADDR="78:2B:CB:56:ED:5D"
NM_CONTROLLED="no"
ONBOOT="yes"

DEVICE="eth4"
MASTER="bond0"
SLAVE="yes"
HWADDR="00:1B:21:C9:F7:38"
NM_CONTROLLED="no"
ONBOOT="yes"

and bond0 is configured as such:

DEVICE="bond0"
IPADDR="10.100.46.3"
NETMASK="255.255.254.0"
NM_CONTROLLED="no"
ONBOOT="yes"

And here is output from /var/log/messages:

Dec  9 08:20:55 app2 kernel: bonding: Warning: either miimon or arp_interval and arp_ip_target module parameters must be specified, otherwise bonding will not detect link failures! see bonding.txt for details.
Dec  9 08:20:55 app2 kernel: ADDRCONF(NETDEV_UP): bond0: link is not ready
Dec  9 08:21:02 app2 kernel: ADDRCONF(NETDEV_UP): bond0: link is not ready

Can anyone offer some insight as to why the driver is failing to start? Is this a dependencies issue?

share|improve this question
    
Have you tried manually executing the ifenslave/ifconfig commands? –  Zoredache Dec 9 '11 at 23:55
    
Just tried it now - yes it works if I do it manually. I have always configured CentOS5 as above and it always worked. –  Lukasz Dec 10 '11 at 0:05
    
After updating the system the link came up - there must be some bug that needed fixing. Thanks for the suggestion! –  Lukasz Dec 10 '11 at 0:27

2 Answers 2

Your log said:

miimon or arp_interval and arp_ip_target module parameters must be specified

Try to add lines below (you can choose your favourite options) to your ifcfg-bond0:

BONDING_OPTS='miimon=1000 mode=6'
share|improve this answer
    
From my understanding bonding options must no longer be specified in the interface configuration files as this is no longer supported as of RHEL/CentOS5. –  Lukasz Jan 18 '12 at 18:41
up vote 1 down vote accepted

Updating the OS with just sudo yum update fixed the issue. Not sure which part did it unfortunately.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.