Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't seem to install MySQL 5.1 on Fedora 16. When I try to install an RPM downloaded from the MySQL website I get conflict errors with the existing 5.5 packages which I have already 'removed' via yum.

TIA SO

# yum localinstall MySQL-server-5.1.60-1.glibc23.x86_64.rpm 


Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Local Package Process
Examining MySQL-server-5.1.60-1.glibc23.x86_64.rpm: MySQL-server-5.1.60-1.glibc23.x86_64
Marking MySQL-server-5.1.60-1.glibc23.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package MySQL-server.x86_64 0:5.1.60-1.glibc23 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================
 Package           Arch        Version                Repository                                  Size
=======================================================================================================
Installing:
 MySQL-server      x86_64      5.1.60-1.glibc23       /MySQL-server-5.1.60-1.glibc23.x86_64       42 M

Transaction Summary
=======================================================================================================
Install       1 Package

Total size: 42 M
Installed size: 42 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /usr/share/mysql/charsets/README from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/Index.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/armscii8.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/ascii.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/cp1250.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/cp1251.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/cp1256.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/cp1257.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/cp850.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/cp852.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/cp866.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/dec8.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/geostd8.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/greek.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/hebrew.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/hp8.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/keybcs2.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/koi8r.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/koi8u.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/latin1.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/latin2.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/latin5.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/latin7.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/macce.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/macroman.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/charsets/swe7.xml from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/czech/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/danish/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/dutch/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/english/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/estonian/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/french/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/german/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/greek/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/hungarian/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/italian/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/japanese/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/korean/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/norwegian-ny/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/norwegian/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/polish/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/portuguese/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/romanian/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/russian/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/serbian/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/slovak/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/spanish/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/swedish/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64
  file /usr/share/mysql/ukrainian/errmsg.sys from install of MySQL-server-5.1.60-1.glibc23.x86_64 conflicts with file from package mysql-libs-5.5.18-1.fc16.x86_64

Error Summary
-------------
share|improve this question

migrated from stackoverflow.com Dec 9 '11 at 22:45

This question came from our site for professional and enthusiast programmers.

    
Come TO easy points! I already solved it. –  Reuben Peter-Paul Dec 9 '11 at 19:45
1  
I'm sure you have a good reason to prefer mysql 5.1 over 5.5. I would rather adapt my existing apps than use an old version. –  mike jones Dec 9 '11 at 20:49
    
I think that installing an old version (5.1) of a software instead of a newer, more robust and more current version (MySQL 5.5) is almost always a mistake. You really should explain well why you want to install an old version like 5.1 (it has more security holes that 5.5) –  Basile Starynkevitch Dec 9 '11 at 21:08
    
Is you application (which motivates you -probably wrongly in my view- to install MySQL 5.1) not working with MySQL 5.5? Why? Won't it be simpler to correct or improve your application instead of severely downgrading your MySQL?? –  Basile Starynkevitch Dec 9 '11 at 21:12
    
We can't have our way all the time. Of course I would rather use the latest version. Thanks for the down vote! –  Reuben Peter-Paul Dec 12 '11 at 14:32

1 Answer 1

up vote 1 down vote accepted

Looks like you still have an old mysql 5.5 package that conflicts with your attempted 5.1 install.

Doing a :

yum remove mysql-libs

should remove it and allow you to properly install your MySQL 5.1 server package.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.