Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I type "ifconfig | more" or "ifconfig | less" the output isn't paginated on Solaris (I'm used to Linux and FreeBSD). Is there a way to do this on Solaris 11?

share|improve this question

2 Answers 2

The reason is, unlike Linux, ifconfig without options isn't a valid command under Solaris. The equivalent command would be ifconfig -a. If you run it without options, ifconfig displays a help message on its standard error stream.

To have it paginated, simply use:

ifconfig 2>&1 | less

By the way, ifconfig is somewhat obsolete under Solaris 11. I would recommended to use the more powerful ipadm instead.

share|improve this answer

You may need to properly configure your terminal type, specially if SSHing from a linux box:

export TERM=vt100

share|improve this answer
    
Thanks, it didn't seem to work. I'm sshing from PuTTY on Win7 box. –  Benjamin Bryan Dec 10 '11 at 0:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.