Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am building a e-mailing app and I am using Amazon SES API to send emails and long with that I am adding the DKIM signature to the email which are being sent. Presently the app is in the testing mode. I am able to send email but one thing I observed in the sent email is that the DKIM sign says dkim="hardfail" which is not a good thing.

How do I configure the setting. I am running ubuntu 10.10 EC2 instance in production and ubuntu 11.10 locally. I have used this GEM https://github.com/jhawthorn/dkim to add DKIM Sign.

Its been already 2 days I am try to solve this issue, kindly help me out.

share|improve this question
    
The only answer here (given that few information) is: You have to do it the right way. –  mailq Dec 10 '11 at 10:35
    
Ensure you are sending using the SendRawEmail command, and check your DNS settings here. If the above fail, post the headers of an email, and more details on what commands, etc you are using to send the mail, as well as any relevant logs from SES. –  cyberx86 Dec 10 '11 at 19:55

1 Answer 1

up vote 3 down vote accepted

Amazon SES requires that you don't sign certain headers in your email while signing with DKIM, as amazon rewrites the headers. From SES developer reference guide:

To ensure maximum deliverability, do not DKIM-sign any of the following headers:

Message-Id

Date

Return-Path

Bounces-To
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.