Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Amazon EC2. I am trying to install lua-devel but I cannot find where it intalls to.

sudo yum install lua-devel

Returns

Package lua-devel-5.1.4-4.1.7.amzn1.x86_64 already installed and latest version

Then

cat /usr/lib/liblua.a

But returns

cat: /usr/lib/liblua.a: No such file or directory

Do you know the directory lua-devel installs to?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

rpm -q --filesbypkg lua-devel

It'll be in /usr/lib64, since it's a 64-bit package. You'll want to yum install lua-devel.i[36]86, depending on what version of RHEL/CentOS/whatever you're running if you need 32-bit libraries for Lua.

share|improve this answer
    
yes i got it. it was in /usr/lib64 –  Maca Dec 12 '11 at 16:13

Did you try to use the locate comand (in addition of a updatedb call) ?

locate liblua.a
>>> list of pathes where liblua.a were found

should tell you where it is installed.

share|improve this answer
1  
Also worth noting that you may need to update the slocate database. I.e., sudo updatedb. –  Andrew M. Dec 12 '11 at 15:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.