Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Setting up a virtual host apache (for Zend framework application) opens XAMPP homepage, but I need Zend default project home page instead.

Am I doing something wrong?

I made a virtual host as follows :

NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
   DocumentRoot "A:\xampp\htdocs\zend_projects\leadscapture_intern"
   ServerName lc.intern
</VirtualHost>
share|improve this question
    
Please edit the question to include all brackets etc. Also post the configuration as code {}-Button –  Lukas Dec 12 '11 at 21:12

1 Answer 1

up vote 0 down vote accepted

As mentioned in the comment edit your question. With that information we are not able to help you.

From the fragment provided by now you should disable (comment out) a couple of lines from the httpd.conf file. The following directives should not appear there:

DocumentRoot /path/to/it
<Directory /path/to/it>
   Options...
   AllowOverride ...
   # directives until the closing bracket
</Directory>

You must enable the include of the vhost.conf file after that, or check for it to be. This is most likely the reason you don't see anything but the default page. It is handled with something like the following: Include path/to/vhost.conf (path and filename may vary).

Last not least check your hosts file and add 127.0.0.1 lc.intern for your browser to actually resolve your VH. Second reason it might not work.

UPDATE: Additionally your VH configuration is incomplete. It should look more like this

NameVirtualHost *:80
<VirtualHost *:80>
    ServerName ic.intern
    DocumentRoot /tra/la/la
    DirectoryIndex index.php index.html
    <Directory />
       Options FollowSymLinks
       AllowOverride None
    </Directory>

    <Directory /tra/la/la>
       Options -Indexes FollowSymLinks MultiViews
       AllowOverride None
       Order allow,deny
       allow from all
    </Directory>

    ErrorLog /path/to/tralala_error
    CustomLog /path/to/tralala_access combined
</VirtualHost>

(quick and dirty)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.